Photoshop CS2/CS3 - Brush lag problem

Discussion in 'Design and Graphics' started by morphineseason, Apr 16, 2007.

  1. morphineseason macrumors regular

    Apr 1, 2007
    Here's the deal:

    I was originally using CS2 on my iMac, which ran fairly well, but I noticed there was some brush lag; by brush lag I mean that the stroke I'm making when drawing something is slightly behind the movement/position of my cursor. It's not a huge lag but it's noticable and pretty annoying.

    Anyways, I thought this might have been a problem with CS2 and the lack of support with the Intel processors (which I have), so I upgraded to CS3 today, and I notice it has the same problem. I've tried everything from resetting preferences, to reinstalling and upping the cache levels and photoshop memory usage. I have 1gig of RAM (plan on upgrading to 2 soon), a 1.83 Intel Core Duo processor, and around 100 gb of hard drive space left. Everything else in photoshop is running a smooth as can be and even the load time is as fast as ever, so I'm really perplexed here.

    Has anyone else had this problem or know of a fix? I've also used CS2 on my PCs with the same specs more or less and haven't had this issue.
  2. Sutekidane macrumors 6502a


    Jan 26, 2005
    Mine does the same thing since I upgraded to CS3, I've never noticed it with CS2 and I have the same specs as you do.
  3. nickel macrumors newbie

    Jul 6, 2006
    There isn't much you can do about it, RAM will not help a huge amount. Its more to do with your CPU. This only happens with fast stroking though. I can't imagine why you would use fast strokes in Photoshop, its not a very good, but still widely used as, painting utility. :confused:
  4. morphineseason thread starter macrumors regular

    Apr 1, 2007
    The thing is, I have a windows laptop with 1.6ghz cpu and 1gig RAM and I don't have this problem on photoshop. It disappoints me because all I ever hear is how macs are made for this kind of stuff. I don't think I should be having this problem.
  5. b3n macrumors newbie

    Apr 24, 2007
    I don't think so... Scott Kurtz ( is having the same problem and he runs a Mac Pro dual Xeon....
    So i guess it's on the software side... Gotta have to wait for an patch update
  6. killmoms macrumors 68040


    Jun 23, 2003
    Washington, DC
    Yeah, apparently this is an issue at the moment. Has anyone seen any sort of official word from either Adobe or Wacom?

    I predict a healthy round of buck-passing between Adobe, Wacom, and Apple until it's resolved—call me a cynic. :rolleyes:
  7. Littleodie914 macrumors 68000


    Jun 9, 2004
    Rochester, NY
    That's only good for machines with more than 4GB of RAM. (I think it actually states that for any machine with less than that amount, you'll see no effect.) The OP said his iMac only has 1GB of RAM currently, so I think we will indeed have to wait for a patch. :(
  8. chaosbunny macrumors 68000


    Mar 11, 2005
    down to earth, far away from any clouds
    Could this be an Intel Mac problem?

    I have a 1,67 ghz Powerbook G4, a Wacom Intuos 3 tablet, an Eizo FlexScan S2110W & CS2 and I don't have any issues unless I move the pen really fast, which I almost never do.

    I'm sure your processor is way faster than mine.:eek:
  9. fivetoadsloth macrumors 65816


    Aug 15, 2006
    Hm thats odd, though I had never used it on a power pc before.

    Either rate, I think well b e waiting for a patch.
  10. morphineseason thread starter macrumors regular

    Apr 1, 2007
    Just an update to this: I re-installed Photoshop CS2 after I installed my 2 gigs of RAM and I no longer have the brush lag issue on CS2 (not sure if it's the RAM upgrade that did it though as CS2 was never using the full potential of my 1gig RAM anyways), however the problem still occurs in Photoshop CS3. This leads me to believe that it has to be a software problem with CS3. My friend who is running a MacBook Pro Core 2 Duo/2gig RAM has the same results with his CS2 and CS3.

    Hopefully Adobe responds to this issue soon.
  11. killr_b macrumors 6502a


    Oct 21, 2005
    So, I got a retail copy of Design Premium and I too totally have a brush lag.

    Check my sig. This is some BS. No updates have fixed it.

    I also have lag on my Apple wireless keyboard now…
  12. Mac Kiwi macrumors 6502a

    Apr 29, 2003
    New Zealand
    Wacom drivers would be my bet for a culprit for those with tablets.

    Must be Intel only as my G5 dual is rocking along with CS3.

    From the hassles I have had with Wacom drivers in the past it sometimes helps to try an older driver.

    Once upon a time there was the same issue with one of the new PS versions {ppc] and then the same with Painter 8 I think it was.It is not uncommon.
  13. Sean Dempsey macrumors 68000

    Sean Dempsey

    Aug 7, 2006
    Same issue here.

    Notable brush lag, with the wacom and mouse. I thought it was just me, but I am glad to see that it's not my computers fault.

    I'm running the Quad 2.66, 5 gigs of ram, Raptor as scratch disk, so for using a plain brush in a 800x800 pixel document, I shouldn't see ANY noticeable lag at all.

    I tried using Adobes fix plugin "Disable VM Buffering" and it had no effect.

    This sorta sucks. At least the brush tracks where it is supposed to, even if it does lag.
  14. bakuretsu macrumors newbie

    Nov 1, 2007
    Same deal!

    I can't tell you all how incredibly disappointed I am to have encountered this problem. I registered just now on the forum so that I could commiserate with everyone and confirm that this is most certainly a software bug.

    Lots of other sites suggest it has something to do with the tablet, as many users who have encountered it are tablet users. This is not so. I can see the lag very noticeably with the tablet and with the mouse.

    To make matters worse, I experience this problem on my brand new 8-core 3.0GHz Mac Pro with 5 gigs of RAM. I expected that even if the CS3 program itself were the most inefficient and bloated in all the world that my machine could power through it enough to let me draw something. Not so.

    It's a good thing I didn't throw down and purchase CS3 Design Standard because I'd be out a thousand dollars; I used the trial first thank goodness.

    It curdles my milk that Photoshop CS2 under Tiger, running in Rosetta, is 500 times faster to simply draw with than CS3, which is supposed to be all UB and efficient and whatnot. Huge disappointment.

    So now I'm torn. I don't really want to buy CS2, either, because it's not a native app. and it's technically obsolete. I own CS1, but wow, what a step backwards that would be.

    I'm chomping at the bit to buy CS3 Design Standard! If Adobe will just fix it so it actually can draw as fast as CS2 in emulation, maybe I will.

    :eek: Deep breaths.

    EDIT: I definitely tried both the enable/disable VM buffering plug-in as well as various RAM and scratch disk settings and the large tiles plug-in. Here is my blog post on the subject with links to the aforementioned plug-ins and some other forums where this bug was discussed.
  15. LeviG macrumors 65816

    Nov 6, 2006
    Norfolk, UK
    to narrow it down a little more. I have my wacom installed on a windows xp machine with cs3, I get brush lag when using it, I never used to get it before the wacom. So I would say its a wacom driver issue or the way in which adobe integrates the graphics driver into photoshop (you can use graphics acceleration in windows version).
  16. V-Trooper macrumors newbie

    Jan 19, 2008
    Hi everyone,
    I recently purchased a Trust TB-4200 tablet and also experienced this lag problem in Photoshop (cs3 as well as cs2 and 7) but the strange thing was that in other programs like Z-brush, SketchBook (even windows Paint) everything was fine
    So I thought that it must be a software issue of Photoshop (I have 2 GB ram and a 3600 MHz pc a very good video card so I dismissed the problem to be hardware based even though Photoshop is quite a heavy program, still simple drawing shouldn’t be a problem)

    Anyway it turned out that the Antivirus software was the problem , I have NOD 32 and Spyware Doctor running at the same time, so I just put the Photoshop .exe in the list of exceptions and the lag was completely gone, the cursor was as responsive as in all the other programs. So if you have this problem try adding the Photoshop .exe in the exceptions list of your antivirus program (I’m not aware of any security issues that might arise from Photoshop) and hopefully that will fix it

    By the way adding it to the exceptions list for spyware doctor didn’t help but shutting the program down did, so this may be the case for other antivirus software too

    Though I still have this problem with my cursor always trembling I don’t know if it’s the tablet , I changed the pen’s battery, strangely it is a bit more calm with an older battery, tried calibrating it, anyway I read somewhere that being close to the monitor or other radio-wave emitting appliances might interfere with the signal and cause trembling in the cursor but I tried it on another computer with nothing else in the room and was as far back as the tablets cable could allow and I still got that trembling so I just have no clue what causes this :confused: . If anyone has suggestions on how to fix that or what’s causing it I’d appreciate info
  17. snickelfritz macrumors 65816


    Oct 24, 2003
    Tucson AZ
    I haven't noticed any brush lag at all in CS3.
    I use large brushes in 300ppi documents and it seems to track the mouse and pen perfectly.
  18. Sweetbike40 macrumors 65816


    Aug 29, 2007
    I am glad i came across this posting. I gave up on my Wacom Tablet because of the lagging. I have to try a few things now. I was having the problem on my Power PC tower on CS2 and CS3. I haven't tried it on my MBP.
  19. Yves Creebs macrumors newbie

    Feb 5, 2008
    Cs3 Lag

    in CS3 make sure that you don't have any high res brushes visible in the panel window. This is a major issue with PS CS3. If you are using high res brushes make sure that you minimize or hide the brushes panel before you start using. Otherwise you will experience extreme lag (up to 2 seconds).

    I have 6 gigs of ram on a quad core and it still does it, so I would guess that no one is safe from this.

    rule of thumb in CS3: only view a small # of brushes in the panel at any given time. If you are using high res brushes, select the brush, then minimize the brush panel.
  20. prozac201 macrumors newbie

    Mar 2, 2008
    Problem Fixed!!!!!!!

    Hi everyone,

    Here's the answer to the CS# / Wacom lag problem!

    The reason why it is lagging on my friends' computer is because of the Double Click Distance.


    It seems what is happening is that when drawing / using pen tool / etc in Photoshop CS3, if the Double Click Distance is set too high in the preferences Photoshop seems to think you're trying to double click, and loads like it's looking for something, creating the lag. Reduce the slider and the problem disappears.

    My Mac doesn't seem to have the problem - I'm using a non intel Mac Pro with CS2, my friend who HAD the problem is using an Intel Mac Pro with CS3.

    Now everything is peachy!!!

    Hope it helps guys - I know what a headache this can cause!!


  21. tera1 macrumors newbie

    Jun 10, 2008

    i am new to this site, i have been searching forever for an answer to this problem. has anyone got any solutions? i tried turning the double click distance down but its still lags in photoshop cs3. i also experience delay using the pen in alias sketchbook pro as well.

    anyone had any luck with sorting this problem?

    currently i run a macbook pro with leopard and have a wacom intuos 3 a4.


  22. bucklee macrumors newbie

    Jun 20, 2008
    Great solution to my lag problem

    I followed the direction with the double click distance adjustment, works great! Not only with CS3 but with all my macbook pro programs....can't believe it was that simple.:D
  23. momomo macrumors newbie

    Sep 27, 2008
    (System: MBP 2.4 Core2Duo / 10.5.5 / Graphire4)

    I had the same problem and found a solution.

    I discovered that an entry (for Beam Sync) in /Library/Preferences/ was missing.

    After adding the following lines and a restart, everything works fine now. :D

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
    <plist version="1.0">
    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
    <plist version="1.0">
  24. tera1 macrumors newbie

    Jun 10, 2008
    how do you actually find the command line for editing?

Share This Page