Photoshop CS3 not recognizing plug-ins

Discussion in 'Mac Apps and Mac App Store' started by D300, May 1, 2009.

  1. D300 macrumors newbie

    Joined:
    May 1, 2009
    #1
    I've just installed Photoshop CS3 on 10.4.x and was unable to open .NEF files from my Nikon D300 or .DNG files that I converted. I upgraded to 10.5.1 and reinstalled Photoshop and still nothing. I went to Adobe's Mac support site and downloaded the most recent camera RAW plug-ins 5.8 or something, then when that didn't work I went back to 5.1 that I knew worked for me on Windows. Both show up as a .plugin file and when clicked I am told they are not recognizable (though they have the right icon). When trying to open .NEFs through Photoshop, they are no longer grayed-out, but the program does nothing when I try to open them or .DNGs.
    I tried to install my Nikon NX software which says Windows/Macintosh on the disc. That froze up and wouldn't let me eject. I tried 8 of the 10 wiki strategies to "force eject" before I could finally retrieve the disc and get back to where I started.
    I'm about ready to pack everything up and send it back... better the devil I know.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    I couldn't read if you you put the plugins in the appropriate place:
    Applications > Adobe Photoshop CS 3 > Plug-Ins .

    Did you do that?

    My camera raw plugin works fine, but with a EOS 450D.
     
  3. D300 thread starter macrumors newbie

    Joined:
    May 1, 2009
    #3
    yes thanks, I put the plug-ins in the plug-in folder.
     

Share This Page