Photoshop CS3 quirks

Discussion in 'macOS' started by zdobson, Feb 17, 2008.

  1. zdobson macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Indiana
    #1
    After using Photoshop for a little while, the lasso tool starts flickering between the lasso and the arrow and won't allow me to lasso anything. If I keep clicking, eventually the lasso will take, but it's obviously not working properly. If I close and reopen Photoshop, it stops, but only temporarily.

    Also, I can set a custom crop size at first, but after changing it once or twice it stops letting me enter anything into the fields.

    Has anyone else had these issues? I'm running CS3 on the mac pro 2.8 octo. I looked around on other sites and seems that other people have had the same issue after upgrading to Leopard. Not just MP users. I'm out of town right now, so I haven't updated to 10.5.2 yet. Just thought I'd see if anyone had any knowledge of this.
     
  2. weevil macrumors newbie

    Joined:
    Jan 3, 2008
    #2
    Yeah, had same problems too with 10.5.1 - loads of issues with Photoshop.

    Good news is that the 10.5.2 update has sorted out most of the problems I was having, so hopefully updating should do the trick.
     
  3. Mr.Noisy macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #3
    No issue with cs3, ive 2 friends using leopard + cs3 also, no reported problems all updates to 10.5.2.
     
  4. zdobson thread starter macrumors 6502

    Joined:
    Nov 9, 2007
    Location:
    Indiana
    #4
    I just got home and installed 10.5.2 and the problem persists. I read somewhere that if I disable spaces it solves the problem. That seems to work, but I love spaces! It hardly seems like a solution to the problem to shut off other features in the OS. Can't they all just get along?
     
  5. MadGoat macrumors 65816

    MadGoat

    Joined:
    Jul 30, 2007
    Location:
    Canada
    #5
    I'm running a default setup of OS X 10.5.2 with all the bells and whistles turned on(Spaces too)... not a single issue with any of the CS3 products.
     
  6. adamberti macrumors regular

    Joined:
    Jan 31, 2003
    #6
    zdobson - did you ever figure out a solution to your problem? I've got the exact same issue and it's really frustrating. Turning off spaces didn't do it for me.
     
  7. HostaDesigner macrumors newbie

    Joined:
    Jan 26, 2008
    #7
    Interesting. Same problem here. My spaces off too.
     
  8. kroniq macrumors newbie

    Joined:
    Apr 17, 2008
    #8
    I too have this problem. CS3 with 10.5.2. I haven't tried disabling spaces though as I need this feature.
     
  9. BlackThunder macrumors member

    Joined:
    Apr 17, 2008
    #9
    Yes I had this problem too... I went back to Photoshop CS since it is so much more stable and runs a lot smoother... and I'm too much of a novice to appreciate any of the upgrades in cs3 anyway.
     
  10. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #10
    you guys with no CS3 problems must not be running InDesign.

    I have 3 separate machines that hang up regularly in InDesign with Leopard that were fine with Tiger.

    I've moved one of them back to Tiger because it has gotten so frustrating. I haven't had any Photoshop issues, though...
     
  11. Halcyon macrumors 6502

    Joined:
    Sep 21, 2006
    #11
    Have you downloaded and installed the ID CS3 update? I only had problems with the G4 and G5 machines at the office, but now all is solved.

    HTH
     

Share This Page