Photoshop CS3

Discussion in 'MacBook' started by esvienne, Apr 21, 2008.

  1. esvienne macrumors member

    Joined:
    Mar 14, 2008
    #1
    Hi there! This is my first post on here but I do lurk regularly. I recently had to reinstall Leopard on my macbook (2.2 santa rosa platform). I had the CS3 suite installed on my computer before and it worked perfectly fine. I went back and reinstalled, and everything in the suite would install but it would error on photoshop. So then I put the CD back in and did a reinstall with just photoshop and shared files, and it still says that it can't install it. I've tried this three times, and I've also tried uninstalling everything and running the cleaner to make sure no fragments were left anywhere. I'm almost tempted to reinstall leopard but I think it may have to do with the updates that were just added. Has anybody else had this problem? I know it's not the CD, it's in perfect condition and it HAS worked before... I think it has to do with my laptop. I did everything the exact same way as before but it won't work. Any help is appreciated!! Thanks! :)

    ~Selena
     
  2. dops7107 macrumors 6502a

    dops7107

    Joined:
    Mar 19, 2005
    Location:
    Perth, Oztrailya
    #2
    I saw this problem on a Mac Mini CoreDuo at work, running 10.5.2. We just installed PS, it was the standalone installation disc. It didn't work the first time, saying shared components could not be installed, but all I did was restart the computer, I think, and I tried again and it worked. I have no idea what happened. This was on a recent re-install of Leopard as well, but I'd be surprised if that had anything to do with it.

    Sorry I can't be more helpful. Are there any installation options you can change? I don't remember the process now.
     
  3. esvienne thread starter macrumors member

    Joined:
    Mar 14, 2008
    #3
    I've tried restarting and everything. We've been on the phone with adobe and apple both, and everything they've had us do isn't working. I'm beginning to think maybe it does have to do with the macbook firmware update... I had installed photoshop before that and it worked fine but this was the only time I've tried after that. The macbook is only a few months old so I know it's not congested. I did a disk verify on the CD and all the permission and everything are fine. I did a verify/repair on my hard drive. Still nothing. If you manage to think of anything though let me know, thanks for trying! Oh, I tried a bunch of options. I tried installing everything together, and all the other programs (illustrator, flash etc) installed fine, but it still rejected photoshop. Then I did the various uninstalls and cleanups, tried to install photoshop alone with the shared components, and it went through the whole install then when it was done told me that it couldn't install. It's just really odd.
     
  4. MacHappytjg macrumors 65816

    Joined:
    Mar 24, 2008
    Location:
    Winnipeg
    #4
    well it happened to my brother on his g5 and this is what he did after trying it twice make sure it isnt touched the computer and no other applications are on and it will work or atleast for my brother make sure its all updated cause i think that caused a problem as well or it was just that but it worked perfectly on my macbook but i onlyp put on flash cs3 and photoshop
     
  5. esvienne thread starter macrumors member

    Joined:
    Mar 14, 2008
    #5
    I'm bumping this up because I'm still having the problem and have not found a thread that has helped me any... there has to be somebody else who has had this problem. So this is the list of what I have tried to fix the problem. (Everything else installs but photoshop has a component install failed) Oh, and just to be clear, it was running before and it failed installation when I did a reformat of OSX.

    1) Reinstall of JUST photoshop and components... fail.
    2) FULL uninstall/reinstall with same problem... fail
    3) Used adobe cleaner to remove all the excess files and did a reinstall... fail
    4) completely reformatted and tried a reinstall of both the whole suite then just photoshop alone.. fail.
    5) Adobe website suggested to make a new user on the laptop and do an install from there... I tried that... fail.
    6) Called Adobe and Apple technical support, they both walked me through clean up processes and mentioned the steps before and they couldn't fix the issue either. I had waited 40 minutes on hold so after this I just didn't want to wait anymore.
    7) I verified permission on both my harddrive and the CD... the CD is practically new with no scratches and my macbook is only 3 months old.

    So as you can see, I'm really stuck as to what can be causing this problem. If anybody else has corrected the problem using a different method or something that I've done wrong, pleaaaaaase let me know. I really think my macbook hates me. It deletes my essays as well as fails to install the only real program I need for picture editing. Lol.
     
  6. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #6
    Try calling Adobe and see if they can't help you troubleshoot.
     
  7. esvienne thread starter macrumors member

    Joined:
    Mar 14, 2008
  8. jbrewlet macrumors newbie

    Joined:
    Aug 22, 2008
    #8
    Same here...

    I have done everything EXACTLY as esvienne has done and I get the same results. I have had this problem since probably March and still have found no one who can answer this problem or has any knowledge of what is causing it.

    I too have talked to Apple and Adobe and they both are no help and in Adobe's case the exact same steps as their website describe.

    Someone out there PLEASE help!
     
  9. Cave Man macrumors 604

    Cave Man

    #9
    Try disconnecting from the internet (i.e., unplug ethernet cable and turn Airport off), then do the install.
     
  10. bartzilla macrumors 6502a

    Joined:
    Aug 11, 2008
    #10
    No idea about your problem's causes but I might have a workaround that lets you get on with things.
    Assuming you can get access to another machine and a external hard disk to store some backups...
    • Backup 'other' machine using something like Carbon Copy Cloner(CCC from now on) so you can give it back to owner as it started.
    • Backup your machine with Time Machine (and probably CCC too just in case). Ensure this is a clean image without any trace of CS3
    • Perform clean install of Leopard on other machine. Patch as needed
    • Install CS3 on other machine as a clean install
    • Patch CS3 as needed. Verify it works.
    • Backup other machine's image with CS3 installed and working with CCC
    • Restore image with CS3 on your machine. It should still work.
    • Restore data & other apps with Time Machine.
    • Restore original CCC image of 'other' machine so you can give it back how you found it.
    • Don't lose your clean install + CS3 image, in case you need to reload OS in the future.

    If my workaround looks like a complete pain, that's because it is.
    However, if the issue is with the CS3 installation then it should leave you with working CS3 on your machine. If CS3 works on the 'other' machine but fails on yours after restoring the image then you have something else to take back to their support folks to tell them about their busted product.
     
  11. jbrewlet macrumors newbie

    Joined:
    Aug 22, 2008
    #11
    Grr

    I was excited at this simple change that I had not done yet. Still didn't work.

    Bartzilla I would love to try your way but my first day of class is tomorrow and I can't afford to dissect my machine right now. Any other ideas?
     
  12. Cave Man macrumors 604

    Cave Man

    #12
    OK, when you get time, try this. Image the Adobe disk with Disk Utility. If it images, then you know you've got a good installer (i.e., nothing is physically wrong with the DVD). Then mount the image, turn off all internet access (i.e., no cables, Airport off) and then try to do the install.
     
  13. bartzilla macrumors 6502a

    Joined:
    Aug 11, 2008
    #13
    That's all I've got. You've got there the cut down method we use at the college where I work to deploy consistent mac application installs over all our machines, I only left out the "install other apps", "upload to server" and "tell minions to rebuild mac teaching labs" parts. If your college uses a similar method, their support people might have the extra equipment to lend you to try something like this.
     
  14. jbrewlet macrumors newbie

    Joined:
    Aug 22, 2008
    #14
    Crap

    Well what do I do when it fails to Image. Obviously I have a bad disk...
     
  15. Cave Man macrumors 604

    Cave Man

    #15
    Yes, if it fails to image then you have a bad installer DVD - and that would explain your problems. Is the disc clean?
     

Share This Page