Photoshop CS4 Font Problem

Discussion in 'Mac Apps and Mac App Store' started by RedElectro, Feb 27, 2011.

  1. RedElectro macrumors regular

    Joined:
    Sep 26, 2010
    Location:
    United Kingdom
    #1
    Hi,
    I've recently downloaded a font from the Google Font Directory to do a mock-up of a website. I intended to use the font in the CSS for all heading etc.

    After installing the downloaded font (Orbitron) I used it successfully to create a mock up of the webpage, then while working on another document, Photoshop quit unexpectedly and when I restarted, only one member of the Orbitron font family would work - reloading the mock-up of the web page told me that fonts originally used were now missing.

    I've tried all the usuals. Restarting the computer, validating the fonts in Font book, removing the fonts and reinstalling, resetting the Photoshop preferences... nothing seems to work, it's like after the crash, photoshop isn't interested!!

    Weird thing is, the font is still available in other software... well apart from Illustrator. TextEdit and Pages can see all the fonts in the Orbitron family fine.

    Oh by the way, it's a .ttf (don't know if that matters) I could really do with getting this working again. Any ideas?

    Thanks in advance.
     
  2. RedElectro thread starter macrumors regular

    Joined:
    Sep 26, 2010
    Location:
    United Kingdom
    #2
    I think I've solved this, if anyone's interest or had the same problem?

    For some reason, the font has installed in my account only - although this doesn't explain why it worked at first.

    I copied the fonts into

    Macintosh HD>Library>fonts
    and deleted the originals at

    User>Library>fonts
    then in

    FontBook I validated the fonts just to be sure.

    Everything's working fine.
     

Share This Page