Photoshop cs4 not supported on architecture

Discussion in 'Mac Apps and Mac App Store' started by elelelelelelele, Dec 8, 2009.

  1. elelelelelelele macrumors newbie

    Joined:
    Dec 8, 2009
    #1
    Hello.

    I bought Photoshop cs4 extended student version and installed it on my mac (Imac os X 10.5.8) but when I wanna open it, it says " cannot open Photoshop because it's not supported on this architecture. I tried to reinstall it a few times but still doesn't work. I don't know what it means "not supported on this architecture" ??

    can someone help?

    please
     
  2. frenchie0101 macrumors 6502

    Joined:
    Jul 3, 2009
    #2
    you have not by any chance moved the folder around in the actual applications folder have you, also to uninstall properly you need to go into adobe's utility folder and run the uninstaller if you haven't done that
     
  3. sdinsider23 macrumors newbie

    Joined:
    Nov 26, 2004
    Location:
    San Diego, CA
    #3
    Usually that only comes up if you try and install intel software on powerpc, i can't remember if cs4 is universal or intel only.
     
  4. andiwm2003 macrumors 601

    andiwm2003

    Joined:
    Mar 29, 2004
    Location:
    Boston, MA
    #4
    i'm pretty sure cs4 is intel only. you don't try by any chance to install it on a g4 or g5 imac?
     
  5. frenchie0101 macrumors 6502

    Joined:
    Jul 3, 2009
    #5
    im sure i come across CS4 being intel only, could be wrong

    EDIT: yeah im wrong its multi
     
  6. elelelelelelele thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #6
    thanks

    thanks for your replies. I finally got it to work. feels stupid now, but I just didn't uninstall it properly. didn't know that I have to go through adobe's utilities to uninstall photoshop.

    THANK YOU for your help
     
  7. frenchie0101 macrumors 6502

    Joined:
    Jul 3, 2009
    #7
    yeah its one of them, its all natural just to send the app to trash from the applications folder, but some progs needs its own uninstaller, i think Microsoft office is the same
     

Share This Page