Photoshop Elements 8 Incompatible?

Discussion in 'Mac Apps and Mac App Store' started by JamJao09, Dec 18, 2010.

  1. JamJao09, Dec 18, 2010
    Last edited: Dec 18, 2010

    JamJao09 macrumors newbie

    Dec 18, 2010
    Hello, I am new to this forum, but very familiar with Apple's Macs in general. I am having a problem with Photoshop Elements 8. The software will not open on my iMac for it says that I am missing applications or something around that ballpark. Once I come home from my gf's house I will be able to give you guys/girls the exact message I get when trying to open PSE8.

    I do not know if the PSE8 is compatible with my current iMac due to its model/year/specs etc. I purchased my iMac around the year of late 2006 early 2007. Should PSE8 be compatible with my iMac or not? I believe it should, but yet I do not know the reason why it will not open.

    PS: I recently purchased the Bamboo Pen & Touch for my gf and it came with the PSE8 software. I Installed the PSE8 on her iMac (Which she purchased the Black Friday that passed.) But before installing the PSE8 on the iMac, the Bamboo installer was installed first. Maybe I need to install the Bamboo installer before installing the PSE8 software that was included with the Tablet product? idk.. lol!

    ***Answers would be much appreciated please!*** Thank you very much in advance :)
  2. MisterMe macrumors G4


    Jul 17, 2002
    Are you trying to install the Mac or Windows version of the software?
  3. JamJao09 thread starter macrumors newbie

    Dec 18, 2010
    Mac version.

Share This Page