Photoshop Elements for Powerbook G4 2004

Discussion in 'Digital Photography' started by katiecuppa, Feb 25, 2012.

  1. katiecuppa macrumors newbie

    Joined:
    Feb 25, 2012
    Location:
    SW England
    #1
    Hi all, I'm new to Mac and I want to stay. The problem I have is I use Elements 7 on my windows laptop, but have been given Elements 8 for Mac. This will not load on my powerbook due to the processor not being up to it. I can't afford to buy new software but love Elements, I can't get on with Apeture.
    Any suggestions ?
    Many thanks.:eek::apple:
     
  2. sapporobaby macrumors 68000

    sapporobaby

    Joined:
    Sep 27, 2007
    Location:
    3 earth minutes from your location....
    #2
    Not quite sure but I think you are out of luck. Your Mac is almost 10 years old and well the processing requirements for Aperture as well as for Elements is well beyond what your computer can handle. Your options might be to purchase a newer Mac or find some older software that will work with your Mac.
     
  3. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #3
    Aperture 1.x should run on your PowerBook assuming that you have a compatible OS. Aperture 2.x may, but I don't know. As for Photoshop Elements, Adobe Photoshhop Elements 6 should run fine on your computer. PSE 6 runs on my PPC-based Mac without issue.
     
  4. sapporobaby macrumors 68000

    sapporobaby

    Joined:
    Sep 27, 2007
    Location:
    3 earth minutes from your location....
    #4
    Good point MisterMe... The question is, well for me anyway, are the products you recommended still avail for sale?
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    Look for them.
     
  6. sapporobaby macrumors 68000

    sapporobaby

    Joined:
    Sep 27, 2007
    Location:
    3 earth minutes from your location....
    #6
    I don't need them. I have a brand new MBP. You made the suggestion, I figured you would complete it and provide the info regarding your post.
     
  7. katiecuppa thread starter macrumors newbie

    Joined:
    Feb 25, 2012
    Location:
    SW England
    #7
    Thank you for the suggestions, I'm hoping that elements 7 may run on my PB g4 but not sure. Otherwise I will look at getting elements 6.
    Thank you all for the replies.:)
     
  8. mofunk macrumors 68000

    mofunk

    Joined:
    Aug 26, 2009
    Location:
    Americas
    #8
    iPhoto is pretty good. You can try and see if that will suite your needs. I remember before I got my MBP, I was looking for a photo editor.... I didn't get it but I think Lightroom 2 will work. There are a few software companies that have products compatible with Intel Macs and G4 Macs.

    If you have any Apple Resellers in your area that also repair macs, they might have older versions of software for G4 Macs running Leopard.
     
  9. joepunk macrumors 68030

    joepunk

    Joined:
    Aug 5, 2004
    Location:
    a profane existence
    #9
    You should be able to run Elements 6 on the PowerBook G4. Any higher version and I believe that an Intel is required.

    Here are the specs for Elements 6:

    PowerPC G4 or G5 or multicore Intel processor
    Mac OS X v10.4.8 through 10.5
    512MB of RAM (1GB recommended)
    64MB of video RAM
    1GB of available hard-disk space (additional free space required during installation)
    1,024x768 display resolution
     

Share This Page