Photoshop Elements

Discussion in 'Mac Apps and Mac App Store' started by larryinca, Jan 20, 2013.

  1. larryinca, Jan 20, 2013
    Last edited: Jan 20, 2013

    larryinca macrumors newbie

    Joined:
    Apr 13, 2012
    Location:
    Sonora CA
    #1
    What is the oldest version compatible with ML?

    Or what versions are compatible?
     
  2. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #2
    Why do you ask?
     
  3. larryinca thread starter macrumors newbie

    Joined:
    Apr 13, 2012
    Location:
    Sonora CA
    #3
    Because I'm not a power user, cheap and want to spend as little as possible.
     
  4. MisterKeeks macrumors 68000

    MisterKeeks

    Joined:
    Nov 15, 2012
    #4
    Same as me. Unfortunately, I don't know.
     
  5. larryinca thread starter macrumors newbie

    Joined:
    Apr 13, 2012
    Location:
    Sonora CA
    #5
    Let's say frugal not cheap...that sounds better.
     

Share This Page