Photoshop files compatable w PS Extended?

Discussion in 'Mac Basics and Help' started by MacMythos, Feb 11, 2010.

  1. MacMythos macrumors member

    Joined:
    Nov 11, 2009
    #1
    I have a nice opportunity to purchase low priced student Adobe Suites right now as i am enrolled in Photoshop CS4 and Illustrator CS4 classes.

    Here is my concern: I would like to purchase the Masters Collection or the Design Premium. Both of these suites have Photoshop Extended. They do not have just plain old Photoshop.

    Will I be confused or unable to use PS Extended if I am learning standard PS in my class?

    Will the DVD of lessons for my class (including images that are to be manipulated in standard Photoshop) work with PS Extended?
     
  2. MacMythos thread starter macrumors member

    Joined:
    Nov 11, 2009
  3. fernandovalente macrumors 6502

    fernandovalente

    Joined:
    Aug 29, 2008
    Location:
    Third world **** hole, I mean, Brazil
    #3
    Everything that is compatible with the standart PS is compatible with the PS Extended. I don't think you will be confused. There are just a lot of other tools on PS Extended. Trust me, PS Extended is much better. I got PS Extended on my Mac, it's great if we compare with the standart one. :)

    Hope it helps
     
  4. MacMythos thread starter macrumors member

    Joined:
    Nov 11, 2009
    #4
    K. Thanks. I'm getting the Masters Collection with PS Extended then. $475:D I don't know if i will ever be able to learn half of that but if i use just one or two of the other programs in the next few years, it will be worth it.
     
  5. fernandovalente macrumors 6502

    fernandovalente

    Joined:
    Aug 29, 2008
    Location:
    Third world **** hole, I mean, Brazil
    #5
    We're always here if you need. :)
     
  6. craighton macrumors member

    craighton

    Joined:
    Sep 20, 2009
    Location:
    Seattle, Washington
    #6
    Yup, Photoshop Extended is exactly like Photoshop but with a few more features, and everything you learn with apply to both versions.
     

Share This Page