Photoshop triggered kernel panic -machines refuses to start

Discussion in 'macOS' started by connieboswell, Jun 20, 2008.

  1. connieboswell macrumors newbie

    Joined:
    Jun 20, 2008
    #1
    Hello - I'm wondering if anyone can help me, and I'm grateful in advance if anyone can.

    On my iMac G5 (isight model) which has 2GB of RAM installed, I opened a large number of layered .psd files in Photoshop, soon after I got a message saying RAM and available disk space were running out, and then the machine seemed to just hang there frozen.

    So, (stupidly perhaps) I forced quit the imac, but on restart I just get the multi-language "you have to restart" message (which I gather is a kernel panic.)

    I've tried resetting the PRAM, restarting with X pressed, with C pressed on the installer DVD, I've put it through the hardware checker, and run it through Disk Utility.

    But still nothing.

    Any clues anyone?

    I guess I've "paged-out" the machine, surely there must be a way round this?

    Could opening way too many Photoshop files have caused an actual hardware fault?

    Yours gratefully if anyone can suggest...

    CB
     
  2. yadmonkey macrumors 65816

    yadmonkey

    Joined:
    Aug 13, 2002
    Location:
    Western Spiral
    #2
    Not likely. Sounds like the problem could be hard drive space - how much free space do you have? Have you tried booting into safe more (hold down shift during startup)?

    Did Disk Utility report or fix any problems?
     
  3. Mr.Noisy macrumors 65816

    Mr.Noisy

    Joined:
    May 5, 2007
    Location:
    UK™
    #3
    1. Whilst using Photoshop, Setting up a scratch disk is a HUGE help with those page outs ;)

    2. No, opening PS files wont cause a hardware fault.
     
  4. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #4
    Thanks for the replies. Appreciated.

    Still have the same problem, and can't get beyond the Kernel Panic screen.

    There should be about 40GB disk space.

    Restarting with shift down doesn't bring up safe mode, and Disk Utility didn't report any problems....

    All I know is I've locked it up somehow by force quitting the imac during a Photoshop session which was way beyond its coping (ie RAM and disk space ran out).

    I'm not blaming Photoshop, but it was the last thing I did on the machine, and it's now like this.

    If anyone has any other suggestions, I'd be so grateful.

    thanks again

    CB
     
  5. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #5
    Do you have any backups? Or external drives? If so, and if I was in your situation, I would have done an archive and install of the OS at this point. It may be drastic but at least you'd be on the road again.
     
  6. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #6
    Thanks for the reply Blue Velvet

    Does doing an archive and install of the OS mean wiping over what is there currently? (sorry if that's a dumb question - I know on PCs you can install an OS and it still keeps the data)

    Much of it was backed up thankfully, but there's always a few bits and pieces hanging around which weren't...

    Thanks again
     
  7. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #7
    Archive and install


    It's not the most elegant of troubleshooting options, admittedly, but the main aim is to get a working machine again.
     
  8. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #8
    Hopefully that could be the solution - much appreciated.
    I've run out of other options, so let's see...

    I'll update on how it goes.

    PS I hope it didn't sound like I was slagging off Photoshop (far from it) it's just Photoshop was the last thing happening on the machine.)

    Thanks again!

    CB
     
  9. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #9
    hmmmmm... not quite so straight forward:

    I get an exclamation mark over the HD icon and the message:

    "you cannot install without changing install settings - a newer version of OSX is installed"

    And Options, it says:

    "destination disk will be erased.":(

    Oh dear

    CB
     
  10. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #10
    Hmmm... Do you have an external Firewire hard drive? Or a copy of Leopard? What OS is on your machine?
     
  11. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #11
    Sorry, I can't see whether it's Panther or Tiger etc - I know it's OSX 10.4 11 (bought in 2005)

    And yes I do have spare Firewire External HDs...

    Thanks!
     
  12. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #12
    that means it is Tiger, from that i can assume your new to macs, or at least fairly new. (whihc is entirely understandable lots of new users these days)

    Im sorry to hear of the issues your having it's always like a great big kick in the balls when a computer mysteriously stops working. Are you sure your correctly choosing "archive and install" from the "there is a new version installed" message it sounds like what your accidently doing is "upgrading" see if you stick your OS X disk into your computer and tell it to simply install and it already sees an OS installed it'll assume you mean "upgrade" but since you got a newer version already installed its stopping you and esssentially saying "whoa! slow down thats not an upgrade thats a downgrade i cant do that"

    So just MAKE SURE your choosing "archive and install" sorry if that sounds like im understating your intelligence i really am not trying to
     
  13. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #13
    Thanks for the input appleqan69 - basically the Archive and Install isn't coming up as an option.

    Here's what I'm doing: I start up with Installer DVD in, agree to licenses etc, then choose Select Destination and it shows my HD as being 465GB (0 bytes free), and a big yellow "!", and the message about "cannot install without changing..."

    Click Option and I get "destination disk must be erased..." and the dropdown Mac OS or Unix choice. Nowhere to go from there.

    Doing my head in!

    The "0 bytes free" doesn't sound good, as I know the disk isn't (or wasn't) 100% full, though I'm guessing the Photoshopping I quit out of doing has left some sort of massive temporary file that's filling it up 100%. All disk checking says the disk is ok, and I even tried removing one of the 1GB strips of RAM - same "you must restart" screen again.

    I'm be dead grateful for any other suggestions.

    Thanks again

    cheers
    CB
     
  14. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #14
    my last thought would be that well as im sure you know when a computer doesnt have enough ram, it'll use the HDD to make "virtual memory" so yeah basically a temporary file.

    Now if you opened ALOT i mean ALOT of .psd files and they were all very high quality, and very high memory, like we are talking 100-300+Mb files and you opened ALOT of them it isn't impossible that your computer was forced to create ALOT of virtual memory. As a result it ended up using more then the HDD could support (more then 40GB) and it crashed. Now that virtual memory file never got deleted so its sitting on your HD, and every time your computer tries to boot it causes a problem.

    I know a 40+GB virtual memory file is ridiculous BUT think of it this way then VM is made it goes like this
    256K
    512K
    1024K (1MB)
    2024k (2Mb)
    4MB
    8MB
    16MB
    (keeps going)
    512MB
    1024MB (1Gb)
    2024Mb (2Gb)
    4GB
    8Gb
    16GB
    32GB
    64Gb <--- see so if your computer needed just 1 byte more then 32GB it would double its VM size into 64Gb which would go above what your HDD could support.

    But still im just rambling on in desperate thoughts because a 32Gb VM file is still ridiculously large.

    EDIT: I was just thinking... its possible since the thought of even a 8GB virtual memory file seems extremely high and something you'd never expect. I mean... like seriously maybe in 10 years it'll be more common then a MB, but right now that seems ridiculous for a vitual memory file.

    SOOO... theres a chance apple really never got around to fully testing/supporiting such large VM files, as a result OS X's kernel saw that and thought "oh **** what do i do?" and well thats when ya get a kernel panic. Thats just anothing thing im throwing out there im honestly not entirely sure if anything im saying is remotely accurate.

    EDIT EDIT: haha I thought of one last thing I want to say (im really trying to help in case you didnt notice :p ) if what im saying is remotely close to the problem at hand. Then if we go a unix nut in here... someone with plenty experience they may be able to give the correct command to delete temporary files or clear any VM etc.

    With that command you could boot into single user mode (can you even get that far?) enter that command and hopefully with that great big VM file gone the computer would be fine and dandy.
     
  15. yadmonkey macrumors 65816

    yadmonkey

    Joined:
    Aug 13, 2002
    Location:
    Western Spiral
    #15
    If you really have 40GB free, then it sounds like you might have damage to the disk directory. I would not recommend an archive/install in this case. If it were my machine, I'd proceed like this:

    1. Boot to another disk (external firewire). If you don't have one, get one because everybody should have at least one large backup disk. I have several because I never want all of my eggs in one basket.

    2. Back up the data from your main hard drive. I probably do this manually, just getting the important data and skipping apps and system files.

    3. Run Disk Warrior on your main drive. It ain't cheap, but if your data is precious to you, then it's $100 (or so) very well spent.

    Depending on what DW comes up with, how you proceed from here may vary. Honestly, I'm anal enough that if I were able to clean the directory on the disk and it looked better, I'd make a second backup (disk image with Carbon Copy Clone or Super Duper). Then I'd wipe the hard drive with disk Utility, choosing the option to zero out the data. This will perform a surface scan in the process and map out any potential bad blocks and clear any doubts about the integrity of your hard drive.

    Then I'd do a clean install of the OS. After that, I'd manually move my important data back to the newly installed drive, but you could probably get away with using the migration assistant, which is much simpler.

    It's a bit of a process, but it's the best way to be sure that you're going to be left with a solid working machine. Of course, you could simply run Disk Warrior and see what that gets you.

    Even if the problem is with virtual memory, then the result is almost certainly some kind of directory damage, in which case, Disk Warrior is your friend.
     
  16. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #16
    Find the big file

    It sounds to me that PhotoShop left behind a really big file (virtual memory) when it closed. You said earlier that you thought your system *should" have 40GB free, but when you tried to reinstall you were getting a zero byte available message. The simplist thing to try first would be to find and delete the VM file. Do you have access to another Mac? You could do a "target mode" start-up (the 2nd Mac starts up connected to the dead Mac, but the 2nd Mac can see the HD of the dead Mac. I don't know where the VM file for PhotoShop is stored, but if you can delete that file you will likely be fine.

    I don't have the instructions for Target mode handy, but they are on the Apple site.

    Good Luck
     
  17. connieboswell thread starter macrumors newbie

    Joined:
    Jun 20, 2008
    #17
    thanks hugely

    Thanks for the tips, I really appreciate all your advice. What I've done is booted to an external HD, and I'm taking it from there... Also put in an order for Disk Warrior.

    What a fabulous tangible relief to at least see the machine working again, with all the data.

    I've learned a lot.

    Big thanks again

    CB:D
     

Share This Page