Photoshop wont open any files!

Discussion in 'Design and Graphics' started by trebor31, Jul 29, 2006.

  1. trebor31 macrumors newbie

    Jul 24, 2006
    Photoshop has started to do an odd thing ...and I am in crisis as I am a photographer and kind of need it!

    It will not open ANY image file, of any size, or any time via any opening method - double clicking on the file, dragging onto the dock icon, using Finder and File Menu>Open or going into P/Shop and using File Menu>Open.

    Photoshop opens fine and does all the usual things when opening an image file - it even gives me the dialogue box when the Colour Settings do not match the work space.

    Then, every time it gives me a message saying: "Could not complete your request because of a program error".

    It give the same message if I try to create a new file within P/Shop.

    Thus far I have:
    - Repaired disk permissions
    - Binned P/Shop prefs
    - Uninstalled and re-installed the whole of Creative Suite 1 (twice!!!)
    - Tried a new user account and the problem was the same.
    - I read about needing to put "Adobe Unit Types" File into a folder called "ScriptingAdditions" at HD/Library/ScriptingAdditions. (This was already there, but I tried an old version from an archived OS 10.4.4, and then downloaded a new version of it from the web and tried that).
    - Put this file in every library I could find on the Mac (that was out of desperation!).
    - Restarted about a billion times.
    - Checked for updates and help.
    - Added any available updates for CS1
    -Trawled the web for hours looking for a solution.
    - Disconnected from the internet while opening a file (As Adobe suggested - like that it gonna do anything?!?!?)
    - run /sbin/fsck -uy at the command prompt after starting up in single user mode.
    - Torn my hair out
    - Sworn a lot.
    -Resisted temptation to put foot through monitor

    I have even tried with Photoshop 7 and installed an old version of Elements 2, but got exactly the same issue and the same message from these as well.

    Frankly, I think I have done pretty much everything possible and am clean out of ideas - any thoughts anyone?

    My info - OS 10.4.7, Photoshop CS1 (Part of Creative Suite CS1).
    This has only happened since I installed OS update to 10.4.7

    Please help!


  2. beatsme macrumors 65816


    Oct 6, 2005
    if this a G4 or G5, you could open up the Terminal, and type this:

    sudo update_prebinding -root / -force

    Make sure the spacing is as above. After that, hit enter and you will be asked for the admin password. Once the password has been typed and you hit enter, the command will run. This will re-link all the necessary files in your applications. If this is a Macintel, I dunno what the outcome will be. You could try it at your own risk.

    After the Terminal finishes, make sure you restart before you do anything else.

    if this doesn't work, you're probably looking at having to do a clean install of the OS.

    you might also try these Terminal commands

    sudo periodic daily
    sudo periodic weekly
    sudo periodic monthly

    run these one at a time...they'll ditch all unnecessary swap files, etc. You don't have to re-start between these 3, but you definitely want to re-start after you've run all of them.

    EDIT: you haven't installed any new software recently, have you? You're running Photoshop all by itself without anything else running the background, correct?
  3. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
    Usually you just need to reinstall Photoshop to fix that problem...
  4. trebor31 thread starter macrumors newbie

    Jul 24, 2006
    Thanks for the advice...but some odd things happened - apologies but I dont understand shell commands, terminal, console etc- so thanks for your expertise:

    I did this and got this message back:
    /var/db/dyld/update-prebinding-paths.txt: No such file or directory

    I tried the sudo periodic commands you mentioned as well but got this:
    /usr/sbin/periodic: line 1: /var/log/weekly.out: No such file or directory

    I presume this is all bad news!

    I have updated to 10.4.7 and updated everything from Software update to the lastest versions. And I installed Camino browser as I was getting fed up of Safari crashing! And I generally run Photoshop with nothing else open other than iTunes so I can listen while I work!

    To be honest, i think my OS is in a right mess...but havent got the install disks with me at the moment as I have just moved house - doh!

    Thanks for the help.
  5. beatsme macrumors 65816


    Oct 6, 2005
    without really looking at it, I'd say yea you've got a mess on your hands. Do the clean this point it's probably you're only option.
  6. iMeowbot macrumors G3


    Aug 30, 2003
    There are much less drastic things to try first. Start with the relevant support document from Adobe. Most of the time, the apple-opt-shift step will fix it.
  7. trebor31 thread starter macrumors newbie

    Jul 24, 2006
    Thanks for all your help and advice....I have literally just got it working - more by fluke than anything, but it works!!! You should see the smile on my face!

    Basically, I have just done again everything all of you have described above, everything listed here: followed by everything listed here followed by everything listed here:

    Then rstarted, uninstalled and re-installed Creative Suite....and it still wasnt working!!

    So out of sheer frustration I re-started and closed P/shop about 5 times holding down Apple+Alt+Shift each tiem to bin preferences - and it now works!

    Presume the system is unstable anyway and as soon as I can get my hands on the install disks I am going to re-install - but thank you so much for the advice that got me on the right path - without you lot of I would have been lost!
  8. netpseudonym macrumors newbie

    Jun 27, 2007
    Hi. I know Trebor31 managed to solve his problem - but for anyone else reading this with the same problem, I just now found my own solution to the same persistent problem.

    I tried everything mentioned above to know avail, and then did the following:

    Open Software Update, and install updates of EVERYTHING it suggests, just to be thorough.

    Simple. worked for me.

    I think it was updating the intel Firmware that did it, but I can't say for sure...

Share This Page