Photostream takes 100% CPU, can't turn it off.

Discussion in 'OS X Mavericks (10.9)' started by coincoin, May 26, 2014.

  1. coincoin, May 26, 2014
    Last edited: May 26, 2014

    coincoin macrumors newbie

    Joined:
    May 26, 2014
    #1
    I have Mavericks on both my imac and my macbook air. When I run Activity monitor on either computer, "Photo Stream" often takes 100% of CPU. It runs for about 5 seconds, disappears for 5 seconds, and reappears for 5 seconds. I have no use for photostream, and this doesn't seem like normal behavior.

    I checked that photostream was deactivated in both iphoto and system preferences. I tried disconnecting from iCloud, but did not change a thing. Any suggestions?
     
  2. coincoin thread starter macrumors newbie

    Joined:
    May 26, 2014
    #2
    fixed

    Update: the problem was apparently caused by my having uninstalled iPhoto, and photostream desperately trying to find it.

    Following this thread:
    http://forums.thedigitalfix.com/forums/showthread.php?t=628362 ,

    I booted in safe mode, rebooted normally, and now all is fine.

    If anyone knows what the safe mode booting does to fix the problem, I'd be curious to know.
     

Share This Page