[php] - php problems os x mountain lion 10.8.2

Discussion in 'OS X Mountain Lion (10.8)' started by cakas6933, Jan 8, 2013.

  1. cakas6933 macrumors newbie

    Jan 8, 2013
    Some days I'm in big trouble with my PHP on OS X 10.8.2 mountain lion.
    I did a clean installation of the x mountain lion and did all the updates. I'm currently with x 10.8.2.
    I activated the apache through the terminal (sudo apachectl start), all right and normal. I tested apache (http://localhost/) on my safari browser, appeared its works!. I edited my httpd.conf through the terminal uncomment the line LoadModule php5_module libexec/apache2/libphp5.so to enable PHP. I created the file info.php in my document root (<? Php phpinfo ();?>). My problem is now, when I go through testing in the browser (http://localhost/info.php) appears only the code (<? Php phpinfo ();?>), Ie, is not playing my PHP. I've done several files. Php and only interprets the code in the browser. Already tested on all browsers and also not worked. Please somebody me some solution, I do not know what's going wrong. I thank all who try to solve my problem. Thank you! :)
  2. s97fever macrumors newbie

    Jan 22, 2013
    Try upgrading the PHP version on the mac OS X.

    I'm by no means an expert and I'm new but I've been trying to apply the steps to upgrade my PHP version from this link:


    Right now I'm on step where you do the Installing
    First, while in PHP’s unarchived source folder, execute the following configure command: and then it lists them 1-57

    I have no idea though how to do that or what they are talking about?
    Any ideas?
  3. phyrexia macrumors 6502a

    Sep 3, 2010
    PHP scripts begin with

    not with

    <? php
    Does this help?

  4. LittleRedBird macrumors member

    Jun 10, 2009
    I went through the same steps and had the same problem as you. Restarting Apache through the terminal solved my problem. The command I used was:

    sudo apachectl restart
  5. safisa1987 macrumors newbie

    Jun 10, 2014
    someone find a solution to the problem
    I know that the post since log time, but really I'm Blocked

Share This Page