phpMyAdmin Root Privileges issue on MAMP

Discussion in 'Web Design and Development' started by Neither, Nov 16, 2009.

  1. Neither macrumors newbie

    Joined:
    Nov 16, 2009
    #1
    This is pretty embarrassing, but I would greatly appreciate any help if you can take pity on this fool. :eek:

    Without thinking I removed all the DB Privileges for the root user in my phpMyAdmin running on MAMP 1.7.1 (OSX 10.4.11)

    Naturally, now I am locked out of editing or creating new DBs in the phpMyAdmin page. The Create new database heading reads "No Privileges" and the Privileges link isnt available. Everything else is working fine and my local sites are still querying the DBs without trouble.

    I am hoping there is some terminal command I can run (?) to get this back into working order but I have very little experience with that level of technical alchemy.

    Again, my eternal gratitude to anyone who can help me out of this embarrassing predicament. :eek:
     
  2. DaReal_Dionysus macrumors regular

    DaReal_Dionysus

    Joined:
    Jan 9, 2009
    #2
    I'll give you an easy resolution:

    go to applications/mamp/db/mysql

    copy all the databases you made you will know which ones they are by the names. Store them on your desktop.

    Next: uninstall mamp, i would recommend the app delete to delete this. It does a much better and complete uninstall if the application. Moving it to the trash will leave the permissions in place so that way you use app delete.

    Reboot and reinstall mamp, then move the data you backed up back in applications/mamp/db/mysql .

    Now restart mamp and you should be good to go.

    Hope this helps.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    I think there's a file you can edit to get it back to defaults, but I don't remember where it is and don't have time to look for it currently. I recommend hitting Google and seeing if you can track down the file. It would keep you from needing to reinstall MAMP.
     
  4. Neither thread starter macrumors newbie

    Joined:
    Nov 16, 2009
    #4
    Thanks for the replies.

    Neonfluxx, cheers for the tip on how to retain the databases after reinstalling MAMP. It's all working perfectly :D

    Angelwatt, I've spent most of today trawling through MySQL and phpMyAdmin manuals and forums and was only able to find info on how to reset the root password and flush/reload SQL commands, but honestly, I'm way out of my depth with all that.

    If you do manage to find the time to check which file can be edited to reset the priveleges table that would be awesome and undoubtedly helpful to others who might get themselves into the same situation. But either way, thanks for the reply :)

    Oh, and to any other people with MAMP issues, I wouldn't recommend bothering with the MAMP forums (http://forum.mamp.info) – they seem to be pretty damn dead.

    Thanks again people. Brilliant to be back working again.
     
  5. DaReal_Dionysus macrumors regular

    DaReal_Dionysus

    Joined:
    Jan 9, 2009
    #5
    Good on you mate. I have worked with mamp for years and know the ins and outs pretty good. Glad it worked for you.

    Best Regards,
    Neon
     

Share This Page