Physical disk not showing in disk utility

Discussion in 'Mac Basics and Help' started by PabloHoney, Nov 23, 2014.

  1. PabloHoney macrumors newbie

    Joined:
    Nov 23, 2014
    #1
    I'm in the process of selling my mac mini.

    I went to the disk utility and erased per the instructions here:
    http://support.apple.com/en-us/HT201065

    The only thing I did differently was I adjusted the security settings to do a pass of writing zeroes.

    Then I went to reinstall OS X per the instructions and there was no drive available on the "select the disk where you want to install os x" screen.
    I tried to do a restore from backup and got the same symptom - no disk to restore to. Also doesn't show when I go to choose a startup disk.

    I went back to the Disk Utility and noticed some weirdness:
    - The Macintosh HD logical volume is showing in the upper left, but there's no physical disk showing as its parent! See attached screenshot - I can repair and verify the logical volume without any problems. It also says that the volume is online and has 1.1 TB as it should.
    I've also tried resetting the NVRAM and PRAM, with no luck

    Any help is much appreciated!!!
     

    Attached Files:

  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    This is because Macintosh HD is a logical volume (you can see it on the bottom there). I'm guessing you either had FileVault on, or you had Yosemite installed. Yosemite is converting disks to core storage volumes like you see here.

    Go back to recovery and in the Utilities menu launch Terminal then run the command below exactly like I have it. That will kill the Macintosh HD logical volume and the disk will then appear normally in Disk Utility for you to format.


    Code:
    diskutil cs delete "Macintosh HD"
     
  3. PabloHoney thread starter macrumors newbie

    Joined:
    Nov 23, 2014
    #3
    Thanks!
    I was actually able to get the problem resolved a different way (maybe not a great way).
    I enabled debug mode in Disk Utility
    http://macs.about.com/od/usingyourmac/qt/Enable-Disk-Utilitys-Debug-Menu.htm

    ...then configured the utility to display all partitions.
    There was a Macintosh HD nested underneath the parent Macintosh HD. I went to the newly-visible nested Macintosh HD, went into Erase and reformatted that to Mac OS Extended (journaled). Then I repaired it.

    After I took those steps, the drive showed up in the Reinstall OS menu.
    Again, probably not the ideal way to go about it, and your suggestion will probably be useful for someone in the future.
     

Share This Page