Pics in camera roll not working

Discussion in 'iOS 5 and earlier' started by gocards, Oct 31, 2011.

  1. gocards macrumors newbie

    Joined:
    Oct 31, 2011
    #1
    I have an iPhone 4 16G and I updated to iOS5 the day after it was availible. I have been using since then and everything has been working great. I have taken about 20 or so pics and nothing has been wrong. Now suddenly when I take a picture it is either 1) blurry and will not focus unless I hit edit, or 2) a white screen with a box in the middle. If I try to edit picture by using auto enhance feature it will show saving picture and once it is saved it will be black. I can email fuzzy picture to wife who has exact same specs as me and hers is fine. She can email me pictures that are fine on her phone and when I save them it reverts back to top. I can put them on computer and they show up just fine. There are also some pictures that were clear 2 days ago that are no longer clear now. Anyone else having this problem? Anyone know how I can fix it? Thank you.
     
  2. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #2
    What have you tried? Home/Lock reset, restore from backup, etc?
     
  3. CK1Czar macrumors member

    Joined:
    Jan 21, 2010
    #3
    I had the same problem of my pics appearing blurry when on my phone but fine when I send them. The problem somehow corrected itself though.
     
  4. gocards thread starter macrumors newbie

    Joined:
    Oct 31, 2011
    #4
    I have tried Lock/home reset. I turned off photo stream. Only way I have found to keep it from being blurry is to take a picture and view it through the camera app. If I try to make as wallpaper or send it though it shows Saving Picture and stalls.
     
  5. A420Turbo, Oct 31, 2011
    Last edited: Oct 31, 2011

    A420Turbo macrumors member

    Joined:
    Aug 17, 2010
    Location:
    NY
    #5
    I have the same exact problem as you gocards. I thought I was the only one. Ive had ios5 since release and just noticed this problem today after using the quick camera function from the lock screen. I also used the + volume button to take the picture.

    The camera was 100% working a day ago and the only 2 new changes I made to the phone before this happened was download zombieville usa 2 and also shut off Setting Time Zone under Location Services > System Services > Setting time zone...

    Idk if any of these are causing the problem but I figure I'd give as much info as possible so we can narrow down this issue

    Another thing I noticed before but I cant reproduce it now. I went to tap the trash can to delete a photo and it said saving photo :confused:
     
  6. gocards thread starter macrumors newbie

    Joined:
    Oct 31, 2011
    #6
    I found our solution!! Found this in another thread.

    http://www.iphoneincanada.ca/how-to...l-crash-and-photos-turned-to-other-in-itunes/

    I did as it said and the first time it did not work because I did a home/lock reset. Brought files back in. Deleted files again and did a soft reset and when phone came back up opened camera roll and it took about 3 seconds for my photos to come up. Only had about 300 due to me deleting off many to try and fix prior. All on pc so none lost. Very grateful I saw this and did not have to restore phone.
     
  7. A420Turbo macrumors member

    Joined:
    Aug 17, 2010
    Location:
    NY
    #7
    Thank you !

    You sir are the man!!! Ive been searching for the past day and its been hard to try and find this exact problem.

    I followed what a few commenters said and only deleted the Photos.sqlite in PhotoData folder. Then rebooted the phone and went to camera roll. It said I didnt have any pictures but after 20 seconds it started restoring the photos one by one. I recommend backing up all pictures but since I only had 20 that weren't important I didn't bother. Also I lost photos that were synced from my computer but i'm sure once I resync they will all be restored.

    I cant thank you enough for finding the solution ! ! ! Now to go and return the favor I'm gonna try and find other people with the same problem and pass on your solution ( With credit to you of course )
     
  8. xXDaddyXx macrumors newbie

    Joined:
    May 29, 2012
    #8
    Can anyone help me?

    so i did everything in the link you posted above, (iphone canada) and when i delete the photos.sqlite , and i reboot, i go on camera roll and all the pictures are blank, it says "camera roll" and when i tap on it, it says i have no photos, now i understand you guys told me to wait a bit for them to show up..well its been over 5 hours .. so i dont know what to do.
     

Share This Page