Pineapple death? Is there anyway to fix iTouch?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Meskalito, Dec 26, 2008.

  1. Meskalito macrumors newbie

    Joined:
    Dec 26, 2008
    #1
    :confused:I have iTouch 1st gen and recently updated it to firmware 2.2, jailbrocken.

    I wanted to erase data on it, but insted of clicking "erase data" have chosen "erase all".. It took about an hour to process..

    As a result: What I see now is boot screen with Pineapple on it. The only way to switch iTouch off is holding power and home button for ~10 sec. I tried to enter DFU mode many times, but w/o success - only pineapple logo. iTunes does not see the device so no way to recover it from backup.

    Any suggestions, is there any way to recover it?

    [​IMG]

    * sigh *
     
  2. MST macrumors 6502

    MST

    Joined:
    Dec 3, 2007
    Location:
    Surrey, UK
    #2
    I had exactly the same problem with my JB iPhone 2G, I to tried putting it into DFU mode but iTunes would not recognise it at all. I was fortunate in that when I jailbreak I always use the stock Apple boot logo and so I was able to take it to the Apple Store where they managed to restore it; they took it out the back so sorry but I have know idea what they did.

    Perhaps someone else here could help, I'm sure all is not lost ;)
     
  3. Morn macrumors 6502

    Joined:
    Oct 26, 2005
    #3
    Are you running 10.5.6? There was a report apple changes the USB kext to ignore DFU mode.
     
  4. Meskalito thread starter macrumors newbie

    Joined:
    Dec 26, 2008
    #4
    Thanks for sharing expirience,

    * keeping my fingers crossed * life is impossible w/o "calendar" %)
     
  5. Meskalito thread starter macrumors newbie

    Joined:
    Dec 26, 2008
    #5
    Indeed, I just googled around and found such reports. Though I also tried iTunes/quickpwn on windows - same thing... They do not detect the device :(
     
  6. svndmvn Guest

    Joined:
    Nov 6, 2007
    Location:
    Italy
    #6
    are you sure You've tried DFU mode correctly in both Mac OS and Windows?
     
  7. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #7
    Not to be a pedant, but there's no indication that the changes were made with that purpose in mind.
     
  8. Meskalito thread starter macrumors newbie

    Joined:
    Dec 26, 2008
    #8
    I've tried a dozen times and was unable to make itouch show "connect to itunes" image and copuner was not able to even detect usb device. I will try again on a different computer once again, in case it switches to DFU but doesnt show appropriate icon...
     
  9. bradenwh macrumors 6502

    Joined:
    Apr 12, 2008
    #9
    DFU mode doesn't have an "appropriate icon." It's a blank screen, like it's off. Unless something is messed up with your hardware, you should always be able to enter hardware DFU mode. If you're running 10.5.6, try using a USB hub. The hub trick worked for me when I jailbroke my sister's iPhone on my aluminum MacBook.
     
  10. capitan bollito macrumors newbie

    Joined:
    Dec 28, 2008
    #10
    problem solved

    i've got your same problem. fixing right now. in progress.
    hold home and power button for 15 sec or more. until jobs appear. must be done while connected to the mac. you'll see itunes will recognise the recovery mode.
    :D

    by the way. you'll have to unlock it again. but better locked and working than pineapple freezed. (and i love pineapple icecream...)
     
  11. iVeBeenDrinkin' macrumors 65816

    iVeBeenDrinkin'

    Joined:
    Oct 17, 2008
  12. Meskalito thread starter macrumors newbie

    Joined:
    Dec 26, 2008
    #12
    Problem solved!

    Life is risky even in Jail ;)

    Thanks guys for support and hints. Indeed all the problems were becouse of 2 things:

    1. I didn't switch to DFU correctly (iTouch must be connected to computer while switching to DFU)

    2. I upgrded to 10.5.6 version of OSX and there are some problems with working with device in DFU mode - solved by using USB hub.

    Yay! :)
     
  13. MST macrumors 6502

    MST

    Joined:
    Dec 3, 2007
    Location:
    Surrey, UK
    #13
    That's excellent news! I'm glad you got it sorted :D
     

Share This Page