Pismo corrup video problem...pics included. Please Help!

Discussion in 'Mac Basics and Help' started by mcnev, Aug 1, 2006.

  1. mcnev macrumors newbie

    Aug 1, 2006
    Hi all,

    Firstly would like to say what a great source of info this place is.

    I am hoping that some of you may be able to help me with a problem I have with my Pismo.

    I was using it recently and all of a sudden the screen flickered slightly then proceeded to corrupt the on screen visuals.

    I closed down the machine and booted back up and it seemed fine at first, but then once again the video became 'corrupted'.

    I left the machine off for a day or so, as i thought there maybe a prob with over heating. Once the machine turned on I heard the chime but there was only a black screen.

    I zapped the PRAM by pressing down the usual keys, allowing the chimes to be heard a few times. This seemed to bring the screen back to life, but then the APlle logo on startup was replaced by whats best described as a 'no entry' symbol (a circle with a line through it).

    I read up via various web pages that this may mean a re install of OSX, I tried that today, by booting from CD, but the graphics became corrupt after a short period and the install seemed to stop.

    I have posted photos of what happened to help you get an understanding of the problem.

    See below:

    Machine Starts Up Via CD

    Video Corruption Begins

    Video Corruption takes over the screen

    To let you know, I have installed an extra 512MB ram into the machine, this was installed well over a year ago and has worked fine.

    Also when the screen is moved/tilted whilst the machine is on, this seems to corrupt the screen too. I have heard that Pismos suffer badly from fractured hinges/clutches, cutting into the cable.

    So what do you think it may be?

    A Cut cable? A damaged daughter card? A Damaged logic board?

    Anything else i havent thought of?

    If any of the above, how easy are they to fix? and also how much to repair? (via DIY)

    Would aprecciate you feedback!

  2. Fearless Leader macrumors 68020

    Mar 21, 2006
    defidently not the ram,
    my guess is the daughter card or a cable has been nocked lose. get that sucker replaced asap.
    and repiaring is hard enough todo when you know the exact problem, not knwing its close to impossible. and youd void your warrenty.
  3. livingfortoday macrumors 68030

    Nov 17, 2004
    The Msp
    This is most likely a logic board problem. It could be a loose cable, but if it's doing it when you're not moving it, that's probably not it. I would try opening it up and making sure the CPU card is in there right, and not loose at all. Also, try it without the RAM you put in, just for the heck of it. I've never had RAM stop working after a year, but it's cheap and easy to check!

    And to the last poster... warranty? On a Pismo?

    Edit: Here's a good place to get a step by step guide to help you take apart the Pismo:
  4. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I have--just poof one day--but I agree that's highly unlikely to cause the problems described. Then again, for the couple of minutes it'll take to test, you might as well.

    One other thing--if you haven't already run the Hardware Test disc (didn't see it mentioned) that came with the computer. If it's a motherboard problem or the graphics chip, it *might* tell you. It won't have the foggiest if it's just a bum cable, of course, but that would be what you're hoping for of course.
  5. mcnev thread starter macrumors newbie

    Aug 1, 2006
    hmmm dont remember a hardware disc come with it, only a OS9 install and recovery disc.
  6. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Hmm... maybe the hardware test discs didn't start until later and I'm remembering wrong, but are you sure there was no shiny silver disc that said something like "Apple Hardware Test" in black letters that came with it?

    If not, forget that advice obviously. If somebody you know has AppleCare or a copy of TechToolPro, you could try the TechTool test disc, for the heck of it.

Share This Page