PISMO G3 squealing noise (loud)

Discussion in 'MacBook' started by kirk wilson, Jul 14, 2008.

  1. kirk wilson macrumors member

    Joined:
    May 18, 2008
    #1
    Hello!

    Has anyone else had problems with an old G3 Pismo making an
    annoying squealing noise when plugged into a charger? There's a lot of
    noises mentioned in mac/apple forums but none of them relate to this one.
    Here's what it is not:
    It's not coming from the screen or the fan or the speakers
    (it's under the keyboard)
    It's not low or slightly annoying (it is a loud squeal)
    It happens only when the power adaptor is plugged into the laptop.
    (it used to cease after I unplugged the power adaptor and plugged it back in
    three times; now that solution doesn't stop the noise anymore)
    It charges ok, and runs ok, scream or no-scream.
    It's quiet right now, but if I move the adaptor to another plug it will start again.


    I was going to live with this, but today after an hour of operating quietly
    it just started again, and I hate to leave the house with this going.
    (it will scream whether the laptop is on or off)

    I have a really old battery and cannot replace it (I am currently staying in Mexico for the summer). Battery life is 45 min. I haven't tried pulling the battery out. That would be too easy.

    This all started when I bought a replacement power adaptor (generic),
    after the original one melted down,
    but I could stop the screaming by unplugging/plugging it in again once or twice. Then I bought an expensive iGo adaptor, and it does the same thing.

    I Did the PRAM and PMU reset.

    I can hear it over music or the tv. It grew lower in pitch today after
    squealing for a half hour. I'd normally not let it go on that long, but i was
    in the other room.

    Is my PISMO dying?


    kw

    (400 mhz pismo G3 500 sdram, osx-10.39, no os-9 or Classic, new 80g HD)
     
  2. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #2
    Sounds like a capacitor is slightly damaged or going out. Though it could be another part of the powersupply system. Though I am not familiar with all of the components in those old powerbooks. It could be the DC-in board assuming the Pismo uses one and it is not just part of the logicboard.

    Perhaps it is the DC & Sound Card part.

    When I had a powersupply going south due to a failing capacitor that made a squeal or buzzing sound. The best I could compare it to when thinking back is say the squelch of a CB radio when getting interference, or AM radio under high voltage powerlines, or just high voltage power lines just higher pitched. This noise would also channel through my analog speaker connection.

    Really I am just speculating as buzzes and squeals are subjective terms.
     
  3. kirk wilson thread starter macrumors member

    Joined:
    May 18, 2008
    #3
    thanks

    i'll check the sound card (i remember reading that it also controls the
    power supply or something)

    But it's quiet for now, so i'm not going to touch it..

    kw
     
  4. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #4
    That is the part I linked to. The DC in and sound card are on the same board.
     
  5. kirk wilson thread starter macrumors member

    Joined:
    May 18, 2008
    #5
    Thanks!

    Sound card.. I totally forgot about that..


    kw
     
  6. Macdctr macrumors regular

    Joined:
    Nov 25, 2009
    #6
    Yup! The problem is in the sound card. What you are hearing is the sound card in the begining stages of failing. This card is what tends to fail the most on the Pismo. I have gotten a few "spares" for my pismo through ebay. :apple:

    Here is the link you will find useful if you haven't done this yet:

    http://www.ifixit.com/Guide/Device/PowerBook_G3_Pismo
     

Share This Page