Plantronics Voyager Pro HD will not launch Siri

Discussion in 'iPhone Accessories' started by robdam1001, Sep 1, 2012.

  1. robdam1001 macrumors 6502a

    Joined:
    Sep 23, 2008
    #1
    I had to replace my older Plantronics Pro HD with a new one; I ran over the old one with my car, lol. On the old headset, I was able to launch SIRI on my 4s simply by depressing the talk button for a few seconds. The new Voyager Pro HD is not launching Siri. Is there a setting that I need to toggle or enable in order to utilize this feature? Thx.
     
  2. robdam1001 thread starter macrumors 6502a

    Joined:
    Sep 23, 2008
  3. mdavis735 macrumors newbie

    Joined:
    Aug 7, 2012
    #3
    I don't know the answer as to how to make it work on yours. Just thought I'd let you know it does work on mine. I just hold the answer button till it launches
     
  4. robdam1001 thread starter macrumors 6502a

    Joined:
    Sep 23, 2008
    #4
    Thx. My old voyager pro hd worked but this new one doesn't. I'm just not sure if it's defective or if there is a setting that I need to adjust.
     
  5. robdam1001 thread starter macrumors 6502a

    Joined:
    Sep 23, 2008
    #5
    My replacement Voyager Pro HD launches SIRI as it should perfectly every time. Guess I got a lemon on the last one.
     
  6. cromeyellow macrumors newbie

    Joined:
    Oct 26, 2003
    Location:
    San Diego
    #6
    Voyager Pro HD does not work with iPhone 4S very well

    I think you'll find, in time, that your replacement Voyager Pro HD is a lemon too. After a while all of them seem to revert to not being able to launch Siri, not being able to lock onto the phone for calls and not being able to re-dial the last number by clicking twice. This is a bad handset with problems, and I read that someone else somewhere on another forum posted the same thing.
     

Share This Page