play single song in iTunes/automatic folder creation

Discussion in 'Mac Apps and Mac App Store' started by xpipe, Jul 9, 2008.

  1. xpipe macrumors regular

    Jul 1, 2008
    Two things I am curious about and can't figure out. Neither is really a "problem," but it's just bugging me...

    1) I ripped a CD to the "music">"iTunes">"iTunes music" folder as specified in the iTunes preferences. I double clicked a song in that folder created to play it. When the song was over, iTunes wanted to automatically play the next song, and so on. In fact, whenever I try to play any song, either from its folder, or in the iTunes library, it does this. Is there a way to get it to just play that one song that I originally selected?

    2) I transferred a folder of assorted songs from an external drive to the "music" folder. As I listened to songs from that folder by clicking on them, it would create new folders for each individual artist in the "iTunes music" ("music">"iTunes">"iTunes music") folder and copy the songs to their respective folders, giving me two copies of the song in the music folder. I don't know that I want them arranged like that. Can I control this?

    By the wac, is iTunes the preferred music player for Mac? Any other recommendations? Thanks very much!

  2. xpipe thread starter macrumors regular

    Jul 1, 2008
    I see...when I rip a compilation CD, it does the same thing(moves songs to individual artist folders)...

  3. xpipe thread starter macrumors regular

    Jul 1, 2008
    As long as I've got your attention, is there any kind of details/information pane in the finder windows? So that when I highlight a file , like a song, I can see all the info on it like size, bitrate, length, etc., without having to right click and select "get info?" Thanks again:D
  4. DeaconGraves macrumors 65816


    Apr 25, 2007
    Dallas, TX
    1) iTunes treats your Music Library like a big playlist. One way to play just one song is to either create a playlist with just that one song or to use the spotlight field in the upper right-hand corner of itunes to enter the name of that song. That way, the song in question will be the only one there and the music will stop at the end. There might be a simpler way but I'm blanking at the moment.

    2) Go to the Advanced tab in the preferences menu. Then go to the general tab. Uncheck "Copy music to iTunes Folder when adding to library and it will prevent the the duplication. For future reference, you could have just used the import function and iTunes would have pulled the music off the external hard drive for you.

    As far as compilation CDs go, if you don't want that, go back to the Preferences->Advanced->General tab and uncheck the option for iTunes to organize your library for you.
  5. xpipe thread starter macrumors regular

    Jul 1, 2008
    Thank you, DG. I'm still just getting my feet wet with this Mac stuff...anything different than what I'm used to is quite a shock to the system :eek:

Share This Page