Play sound from internal speaker with earphone plugged in?

Discussion in 'iMac' started by resting, Aug 20, 2012.

  1. resting macrumors member

    Aug 15, 2011
    As above.

    I usually play mousic through the speakers. Only when I need to listen to some dialogues, then I'll plug in the earphone for clarity.

    Its a troublesome process since I have to turn the monitor each time I do that.

    Is there a way to keep the earphone plugged in, but have control as to whether the sound plays through the speaker or earphone?
  2. Apple fanboy macrumors Core

    Apple fanboy

    Feb 21, 2012
    Behind the Lens, UK
    There maybe a better solution than this but I saw an iMac turntable in one of the setup threads on here.
    Either that or can you leave your earphones connected but not all the way? That way the speakers will work, and then just feel round the back to push it home when needed.
  3. comatory macrumors 6502a


    Apr 10, 2012
    EDIT: sorry didn't read properly. Try this:

    Why not just get cheap headphone amplifier?

    Some of them have individual volume knobs for earphones and speakers. Correct me if I'm wrong but you do have external speakers? If not there might be some sort of software controller (check out Soundflower, it can do bunch of things).

    Or external sound card might work for you as well.
  4. resting thread starter macrumors member

    Aug 15, 2011
    That's more for like people who wants to share their screens I suppose. The other problem I'm facing is I don't have a spacious place to turn the monitor. Also, would like to minimising the plugging/unplugging of the earphones too.

    I don't have external speakers. The internal speakers works very well for me. Its for office use anyway.

    Amplifiers so I could blast music through headphone instead? Nah..the quality wouldn't match the internal speakers.

    Soundsource might just work for me. Will try it out tomorrow. Thanks!! :D
  5. resting thread starter macrumors member

    Aug 15, 2011
    ahh...just tried. the options changes from internal speakers to headphone when i plug in my earphones :(

    cant force it to bypass it.

Share This Page