Playing with iPhone wakes up iMac, why?

Discussion in 'macOS' started by johannnn, Jul 23, 2017.

  1. johannnn macrumors 65816

    johannnn

    Joined:
    Nov 20, 2009
    Location:
    Sweden
    #1
    We have an iMac in the bed room. Today I woke up extremely early so I went outside the bed room to play with my iPhone. Three times during the night my SO woke up and told me to put the bright iMac screen to sleep. Somehow it woke up from sleep and displayed the login screen.

    - My Apple Watch can login to my iMac, but I did not wear it.
    - The iMac and iPhone are both on latest OS, on same wireless internet, and within Bluetooth range.
    - I didn't do anything special on the phone, just played around with various apps like reddit, safari, twitter etc.

    Is there any known reason why an iPhone can spontaneously wake up an iMac? I love the macOS sleep mode and don't really want to turn the iMac off every night.
     
  2. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
    #2
    You got handoff and "wake with iPhone" enabled on the Mac? If so,it's set to wake when iPhone is nearby.
     
  3. johannnn thread starter macrumors 65816

    johannnn

    Joined:
    Nov 20, 2009
    Location:
    Sweden
    #3
    Yep I got Handoff enabled.
    But I don't see any option for whether the phone should also wake up my Mac?
     
  4. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
    #4
    There is one such option in Mac settings somewhere. It's almost the same as using Apple Watch to wake up macs.
     
  5. johannnn thread starter macrumors 65816

    johannnn

    Joined:
    Nov 20, 2009
    Location:
    Sweden
    #5
    Turns out it's not the iPhone, it's my AirPods! When I open the lid of the case, the iMac wakes up. How the hell do i stop this from happening?
     
  6. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
    #6
    Check the Bluetooth settings on the Mac,remove the AirPods if they are mentioned there,or set Bluetooth to manual connect.
     
  7. johannnn thread starter macrumors 65816

    johannnn

    Joined:
    Nov 20, 2009
    Location:
    Sweden
    #7
    Little bit annoying to manually disconnect the AirPods all the time, no?

    Now my TV wakes up sometimes too when I grab my AirPods (the TV turns on the TV).

    Seems like my AirPods likes to wake up all my  devices :confused:
     
  8. SmallDane macrumors member

    SmallDane

    Joined:
    Dec 23, 2014
    Location:
    Denmark
    #8
    And it even wakes up your SO. :p
     

Share This Page