Playing YouTube video causes iTunes songs to freeze

Discussion in 'Mac Basics and Help' started by bizzwriter, Mar 24, 2018.

  1. bizzwriter macrumors member

    bizzwriter

    Joined:
    Aug 4, 2010
    Location:
    Left coast...
    #1
    I've had a problem for the past couple of months where when I play a YouTube video (hard to avoid them nowadays -- many websites use YouTube to host videos), my iTunes songs freeze. I press PLAY and nothing happens. Then, when I try to play another YouTube video, it's frozen too. Basically, I'm unable to play any online video or audio track.

    This occurs no matter what browser i use (Chrome, Firefox, Safari). If I switch to a different browser, it's frozen too. The only cure I've figured out is to restart my computer.

    I've got an iMac 5k 27-inch, 2017 4.2 GHz Core i7 running High Sierra 10.13.3.

    Anyone else run into this problem? If so, what did you do to cure it? I've done a bunch of searches and can't find any posts for anything like this.

    Thanks!
     
  2. techwarrior macrumors 65816

    techwarrior

    Joined:
    Jul 30, 2009
    Location:
    Colorado
    #2
    I typically use USB headphones on my Macs. A\V freeze is a common thing for me, somehow the headphones are "forgotten" by my Mac. Without an audio path, the media freezes

    To resolve, i simply unplug the US headset, then replug them and I am good to go.

    This has been going on for a couple of years, at one time Apple claimed to fix this in one of the OS updates, only to have the problem come back later.
     
  3. bizzwriter thread starter macrumors member

    bizzwriter

    Joined:
    Aug 4, 2010
    Location:
    Left coast...
    #3
    Many thanks @techwarrior ! Now that you mention it, this new phenomenon coincides with my purchase of an Audioquest DragonFly Red USB DAC. I'll bet that's it. Next time this happens I'll unplug/replug the DAC and see if that works. THX
     
  4. bizzwriter thread starter macrumors member

    bizzwriter

    Joined:
    Aug 4, 2010
    Location:
    Left coast...
    #4
    Wow -- that was it. iTunes audio was frozen again just now. Unplugged my USB DAC, then replugged -- audio UNfrozen. Worked like a charm. MANY thanks, @techwarrior -- that was a pretty esoteric problem/fix!
     

Share This Page