Please Advise: High Sierra Installation Failed on 2011 MBP

Discussion in 'Mac Basics and Help' started by Sharkoneau, Sep 25, 2017.

  1. Sharkoneau macrumors 6502

    Sharkoneau

    Joined:
    Jan 13, 2017
    Location:
    Michigan
    #1
    Hey guys,

    I’m not the most knowledgeable person about macOS recovery and software issues, so I thought I’d seek help here.

    I attempted to install High Sierra on my 2011 MBP, running an HDD. My install failed, the installer saying the proper file system checks on the hard drive could not be completed. I restarted and attempted the install again; this time, it said the software package was damaged or missing.

    I’ve tried quitting the installer, shutting down, what have you. Even opened up disk utility, though I don’t exactly know how to utilize it. Luckily my important content is backed up to multiple places, but I have no backup software image for Sierra or High Sierra. I’m at an impasse.

    Could anybody recommend a way to proceed? I’d love to get things working again. Also, apologies if this has been posted in other threads - just trying to reach out before hitting the hay.

    Thanks!
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    If you haven't tried it yet...
    ... I'd recommend that you create a bootable USB flashdrive with the installer on it.

    You can do this by using (either):
    - Install Disk Creator
    - DiskMaker X
    - The terminal app.
    The USB flashdrive should be 16gb or larger.

    I find this works much better than "online installs", etc.
     
  3. Audit13 macrumors 6502a

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #3
    You also perform an internet Recovery, open disk utility, erase the disk, reinstall the os that came with the machine.

    To access in internet recovery, shut down the machine, boot while holding down command+option+r.
     
  4. Sharkoneau thread starter macrumors 6502

    Sharkoneau

    Joined:
    Jan 13, 2017
    Location:
    Michigan
    #4
    Hey all (@Audit13 , @Fishrrman ), sorry for not seeing these replies sooner! I don't receive notifications for messages without tags or those not using the reply function.

    Seeing as the file system verification checks did not pan out originally, I opened up Disk Utility and performed first aid on my drive. After this, the Mac rebooted, and successfully installed the update. Everything seems to be running fine with no issues! Thanks for the input you two.
     

Share This Page