Please Help - 2007 2.2GHz MacBook Upgrade Issue

Discussion in 'MacBook' started by azbutler, Dec 13, 2012.

  1. azbutler macrumors newbie

    Joined:
    Aug 7, 2009
    #1
    I decided to breathe some new life in to my 2007 2.2GHz MacBook by:

    -upgrading the RAM to 4gb w/Centon memoryPOWER 2GB DDR2-667 PC2-5300 CL5 SO-DIMM Laptop Memory Module
    -replace the HDD with a SSD (Samsung 840 Pro-Series MZ-7PD128BW 128GB SATA 6.0Gb/s 2.5" Internal Solid State Hard Drive).
    -Also going from Leopard to Snow Leopard after the hardware upgrade, then possibly Lion/Mountain Lion...

    What I've already done:

    1. Backed up my hard drive using time machine, did not clone
    2. Using the install disc/Disc Utility, I erased my old hard drive completely (Hope that wasn't a huge mistake!)
    3. Replaced the previous 2gb (1x1gb) with the new 2x2gb RAM sticks
    4. Swapped out the HDD with the SSD

    When I went to boot the machine, all I get is a black screen. I can hear the optical drive spin for a while, then stop. Screen remains completely black. I have tried using C while starting as well as Control - same result. So, I put the old (erased) HDD back in and again got the same result. I didn't have time to put the old RAM back in and try again before work this morning and intend to tonight. Based on that, maybe my RAM isn't compatible even though the specs look to be...? But, does anyone know if the components I am using are not compatible? or did I totally screw up by erasing the old Drive prior to confirming this would work? Am I missing something else?

    Any help would be MUCH appreciated!
     
  2. Zotaccian macrumors 6502a

    Zotaccian

    Joined:
    Apr 25, 2012
    #2
    I'm sure you have already tried with the old RAM by now, that's what I suggest first. The RAM you bought is compatible by just looking the specs, but of course there could be some weird compatibility issues, I have never faced one even though I always put whatever memory I have (that meets the specs of course) laying around in these machines. Hard disk is not required for the machine to display picture, but since it does not work with the old one it is bit worrying. Check that you have connected every possible cable properly and that RAM sticks are properly inserted, try with only one stick also.
     
  3. azbutler thread starter macrumors newbie

    Joined:
    Aug 7, 2009
    #3
    I was finally able to get it done using my old RAM, so that must be the weak link. I'm going to try to return the RAM I bought and try a different brand. Thanks For the help!
     
  4. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #4
    If you are interested in using Newegg, this G. Skill set is CL 4 (most are CL5) and this is $48.99. If you use ebates you get a little bonus cash back too.
     

Share This Page