Please Help ASAP! iPhone won't start or boot after opening it to change lcd!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by apocalypse333, May 20, 2009.

  1. apocalypse333 macrumors newbie

    Joined:
    May 20, 2009
    #1
    Hi,

    Please I need help asap as I'm without a phone at the moment. I tried to open my iPhone 3G following youtube videos and directions online.

    I undid the two bottom screws then used a suction cub to seperate the screen from the body. Then I removed the connectors for the screen, #1, then #2, but left #3 in place. While I was working on removing the old lcd, #3's ribbon popped-out (without my first popping up the plastic holding).

    So I got nervous and quickly replugged the #3 ribbon (a small piece of the plastic holding for it as well as one pin broke off), I reconnected connectors #2, then 1, and close the iPhone.

    Now when I try to hold the power button, nothing happens, no boot logo, no sound, no burning smell, nothing. Please help me out, I don't know what went wrong, even if the connector #3 ribbon is broken, it is supposed to control the phone speaker, so the phone should still open right?

    I'm really tired and lost at what to do, could it be that my screwdriver touched the logicboard and it short circuited (it was off at the time of disassembly)?

    I appreciate any help,

    thanks
     
  2. apocalypse333 thread starter macrumors newbie

    Joined:
    May 20, 2009
    #2
    Please, I just opened it again today, #4 and #1 connectors are clicked in perfect, plz what is the problem.

    thanks
     
  3. apocalypse333 thread starter macrumors newbie

    Joined:
    May 20, 2009
    #3
    Thank God, I'm so happy I got it to work. For anyone having a similar problem, plug the iPhone into the pc with the usb cable, my lcd may be cracked, but now it shows the battery screen.

    I think when I opened the phone, the battery somehow got reset, now I only need to replace the lcd and it's all perfect.
     
  4. elnegrocarme macrumors newbie

    Joined:
    Jan 25, 2010
    #4


    i plug it to a pc and nothing,, what else u do?
     
  5. Rob1980 macrumors member

    Joined:
    Feb 25, 2006
    Location:
    Ramsgate UK
    #5
    The same has happened to me today when I replaced the digitizer screen. It apears that the iPhone will not charge like the above post states " battery somehow got reset".

    I have tried holding the home and power button to reset and have managed to do a restore. The new digitizer is not working aswell :-( just to top things off

    has any one got any ideas?
    Rob
     

Share This Page