Please, help! Bluetooth not working iMac a1419 2015

Discussion in 'iMac' started by BUVET, Aug 1, 2019.

  1. BUVET macrumors newbie

    BUVET

    Joined:
    Aug 1, 2019
    Location:
    Russia
    #1
    Ok. I have this card
    BCM943602CDP, wi-fi working perfectly, but Bluetooth not working. I made all things, like delete Bluetooth pref, SMC, NVPARAm, all that wrote by many people. Apple Diagnostic - all good. No wrongs or any errors. What can I do? iMac 27 5K late 2015 A1419.
     
  2. kretek macrumors member

    Joined:
    Oct 15, 2008
    #2
    If you are using Android File Transfer, delete it, as this has been an issue for some users with the same Mac.
     
  3. BUVET thread starter macrumors newbie

    BUVET

    Joined:
    Aug 1, 2019
    Location:
    Russia
    #3
    No, i'm not use this program.
     
  4. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Does the Bluetooth hardware show up in your System Information/Bluetooth tab?

    Is there any change after reinstalling your macOS?
     
  5. BUVET thread starter macrumors newbie

    BUVET

    Joined:
    Aug 1, 2019
    Location:
    Russia
    #5
    No it doesn’t show up in hardware. Yes it change after reinstall Mojave
     
  6. jamesweingarten macrumors newbie

    Joined:
    Aug 5, 2019
    Location:
    2450 Hollywood Blvd Ste. 200B
    #6
    If you do now see the Bluetooth icon in the menu bar, go to System Preferences > Bluetooth and check the “Show Bluetooth in menu bar”.
    You may think that Bluetooth seems to be not working because your Bluetooth device stopped working. It is simple that your device battery is running very low, if it uses battery. Make sure that your Bluetooth accessories has enough battery life. You may want to change the batteries or charge the device.
    1. Make sure that Bluetooth device is turned on.
    2. Make sure that your Bluetooth device and Mac are close to each other.
    3. Restart your Mac. Simply restarting your Mac may fix your problem.
    4. Disable and enable Bluetooth. Disable Bluetooth and wait several seconds and then turn it on.
    5. Remove all USB devices (mouse, keyboard etc) and then reboot your Mac and then reconnect them.
     
  7. BUVET thread starter macrumors newbie

    BUVET

    Joined:
    Aug 1, 2019
    Location:
    Russia
    #7
    I can’t see Bluetooth icon in preferences. When I Connect external Bluetooth, I see this icon and all work good and fine.
    But, if it will be problem with internal Bluetooth Apple Diagnostic will show error about Bluetooth, but no errors!
     
  8. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    I suggest that you boot to your Mojave installer, and reinstall the system.

    Are you still having a problem of some kind?
    You said "When I connect to external bluetooth, I see this icon and all work good and fine"
    What is NOT working now?
     
  9. BUVET thread starter macrumors newbie

    BUVET

    Joined:
    Aug 1, 2019
    Location:
    Russia
    #9
    Let see. In wi-fi card is internal Bluetooth, that’s work under installer, but i’ve external ASUS now, that’s not work under installer, and when I reboot to windows or back to os, I must reconnect my keyboard and mouse with cable. And then it’s work good!) It’s not native support by this external Bluetooth by ASUS.
     

Share This Page

8 August 1, 2019