PLEASE HELP!! Cannot restore my backup onto new hard drive

Discussion in 'Mac Basics and Help' started by maclook, Sep 12, 2009.

  1. maclook macrumors 65816

    Nov 2, 2008
    PLEASE HELP: I recently bought a new hard drive for my 2006 MacBook but have run into nothing but problems while trying to restore my time machine backup onto it. Using my Leopard Family Pack disc, I was unable to format my drive successfully so I scheduled an appointment with the Genius Bar. When I went, the Genius used his USB hard drive to format the drive and install Leopard. While using that, he ran into no problems that I had run into while using my Leopard disc. So Leopard is installed and I go home to restore my backup and the backup fails (Migration Assistant and booting from Leopard Disc). So I schedule a second appointment and the Genius tells me there's no way he can attempt to restore my backup due to time restraints (which is understandable) and runs diagnostics on my hard drive and the time capsule's hard drive, finding no issues. He installs Leopard again on my new drive and I go home to run into the exact same problems I did last time. I don't know what to do, the Geniuses won't help me, and I can't find the answer on the internet.

    Here's a list of the things I have done and the errors I run into:

    Migration Assistant - after getting Leopard installed by the Geniuses at the Apple Store, I come home and run Migration Assistant with my Time Capsule attached via ethernet cable. Everything runs smoothly until one of the last steps (which says under a minute remaining) "Transferring support for applications". It just sits at that stage forever and I have read online about similar issues. I read online that somebody quit out of migration assistant at that point and everything was transferred over anyways. This isn't the case with mine, as over half of my dock was filled with question marks.

    Restore backup from Leopard Family Pack disc - This is the disc I used to originally install Leopard on my Mac. When i boot from the disc, I choose English as the language and immediately following that I get the message "This software cannot be installed on this computer". This happened when I had a brand new unformatted hard drive so I used disk utility and when I tried to partition it, it failed. After the Apple Store guys formatted my drive and installed Leopard, and after Migration Assistant failed on me, I booted from my Leopard Family Pack again and got the same message so I know for a fact that it is not related to the hard drive.

    Restore backup from Snow Leopard UTD disc - a friend of mine got an UTD disc so I borrowed it to use on my brand new hard drive. It tells me that it requires Leopard to install but gives me the option to restore from a Time Machine backup. I choose my Time Capsule and then choose my backup that it finds. It continues to tell me that it is erasing the hard drive and at the point an error message pops up saying there was an error and to restart my computer. After doing so, my hard drive is no longer formatted correctly and I have to go to the Apple Store to get them to use their USB hard drive to format my hard drive and install Leopard (starting this whole process over again)
  2. McGiord macrumors 601


    Oct 5, 2003
    Dark Castle
    can you try this:
    1- boot with your OS X Leopard disc
    2- format one HDD
    3- Install Leopard
    4- Recover your time machine back up
    Now you have your 'old' computer back, check everything is like is was.

    Then use a 2nd HDD:
    1- format it
    2- Install Snow Leopard
    3- transfer your users with Migration Assistant
    4- if it fails then just copy the user home folders manually, install the apps

    Note that many applications are not compatible with Snow Leopard and they will show their icons as question marks on the dock.

Share This Page