Please help! Can't use my administrator privelages

Discussion in 'Mac OS X Lion (10.7)' started by Manic Harmonic, Mar 28, 2012.

  1. Manic Harmonic macrumors 6502

    Joined:
    Dec 4, 2011
    #1
    Yesterday i was playing around with my macbook... I had refit installed on a second drive and was using that as a boot menu. It worked fine. I deleted the first os on that partition because I wanted to make a dedicated audio partition. I installed refit on the main drive instead.
    All of a sudden i'm having tons of problems. lion wouldn't start on second boot, kept getting white screens on startup... etc. I also have no admin privelages. i managed to boot into sl on the second drive finally, and deleted refit from the lion drive and installed it on snow leopard.
    now everything boots fine, the only problem left is that I still have no admin privileges in lion.
    In system preferences, it shows me as admin, but I can't unlock it. I reset my password, and that worked fine, but I still couldn't unlock. I also tried deleting the syst pref cache but that didn't help either....

    Also, in both lion and SL, there is a "fseventsd-uuid" unix executable file that I've never seen before in the trash. I can't empty the trash of course.

    What can I do? I'm having trouble finding any information on these boards or on google.
     
  2. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #2
    Before boot hold Command + R.

    Select disk utility -> Repair permissions.

    In the upper menu bar go to utilities-> terminal

    type "resetpassword" without quotes.

    Restore permission on YOUR user from the drop down. Don't reset password.
     
  3. Manic Harmonic thread starter macrumors 6502

    Joined:
    Dec 4, 2011
    #3
    Thanks for the help. Unfortunately, before your post, i made the decision ti reinstall via the recovery partition. The first time it said it could not download the additional components. Im trying it again, the installer log retried 2 times to download installesd.dmg, followed by "chunklist is production signed." however, there are no more errors sonfar and the progress bar is moving.... I shall see what happens.

    Also... I got a notice from apple on my ipad telling me i had to reset my password. Would that have anything at all to do with this????
     
  4. Manic Harmonic thread starter macrumors 6502

    Joined:
    Dec 4, 2011
    #4
    The reinstall finished, and everything works as it should, although I wish I would have seen your post before blatopilot, it would have saved me a lot of time. I'm not sure what it was that caused this but all is well in the administration world.
     

Share This Page