Resolved PLEASE HELP - Clean Install Snow Leopard Failed & Disc Stuck

Discussion in 'Mac Basics and Help' started by iapple12399, Apr 11, 2015.

  1. iapple12399, Apr 11, 2015
    Last edited: Apr 12, 2015

    iapple12399 macrumors newbie

    Joined:
    Mar 21, 2015
    #1
    Hi so I'm trying to do a clean install of Snow Leopard on an iMac mid 2007, 4gb ram 250gb HD. The iMac was working fine before, but when I tried restoring it to factory settings using original Snow Leopard install disc, going to Disk Utility, erasing HD, then clicking "install" for software, the software install keeps failing, it keeps saying "an error has occurred." I tried reseting the PRAM and reparing the drive through disk utility and trying to install again, but no luck. I think the disc was dirty but I can't even eject the disc! I tried command+E, using terminal and commad+s and typing "drutil eject" as well as holding F12 and left/right clicking mouse and nothing.. I can't even click anything else but the install disc upon set up. Please help me out to fix this, would appreciate it so much, thanks!
     
  2. aicul macrumors 6502a

    Joined:
    Jun 20, 2007
    Location:
    no cars, only boats
    #2
    Try these, hope they work

    restart
    before first bong press CMD+ALT+O+F
    then on the screen type "Eject CD" press enter
    wait

    hopefully the disk ejects

    then type "mac-boot" to start OS X (but this may not work as you were installing)
     
  3. iapple12399 thread starter macrumors newbie

    Joined:
    Mar 21, 2015
    #3
    can't get the mac into that cmd+alt+o+f firmware, i'm using a non apple keyboard but pretty sure the keys still work the same as i use the windows symbol as the command key to get into that command+s screen.
     
  4. iapple12399 thread starter macrumors newbie

    Joined:
    Mar 21, 2015
    #4
    Resolved! Tried holding the mouse button a few more times, this time with an apple mouse and before turning on the computer and the disc eject worked!
     

Share This Page