Please help! Echoing iMac speakers

TomSGH

macrumors newbie
Original poster
Jun 11, 2012
3
0
Hey all.
Sorry if this is in the wrong place.

I had a problem with my late 2008 imac earlier.

Restarted it and I got stuck at the login screen. Looked on the internet (on my phone) and fixed that problem.

Got it running once more, opened Spotify and played a song and the audio settings are just way off, I noticed a huge change straight away.

Sounds tinny, echoing and as if someone has turned stereo off.

I have looked around in settings to no avail yet, hoping someone can help point me in the right direction.

Tom
 

flatfoot

macrumors 65816
Aug 11, 2009
1,010
3
Have you tried another reboot? That helped me a few days ago when I had echoing speakers.

Might also be that there's something wrong with your kexts (drivers). Try repairing permissions in Disk Utility.
 
Comment

TomSGH

macrumors newbie
Original poster
Jun 11, 2012
3
0
I've tried a reboot yeah. Still same old crappy Noise quality.

I'll have a go at your suggestion when I get home, thanks!
 
Comment

TomSGH

macrumors newbie
Original poster
Jun 11, 2012
3
0
Well I tried both of your suggestions and everything seems to be back to normal, so top result!

So thank you both for taking the time to answer my question, I really am terrible when it comes to getting technical with computers!

Cheers, chaps!

Tom
 
Comment

elev8d

macrumors 6502
Dec 9, 2008
326
84
Do you have your mic on? It could be causing a feedback loop.
Just a thought...
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.