Please Help! Firefox 3.0.3 won't start in OSX 10.5.5

Discussion in 'Mac Apps and Mac App Store' started by Toddo, Oct 13, 2008.

  1. Toddo macrumors newbie

    Joined:
    Oct 13, 2008
    #1
    I've tried searching for this and haven't found another thread so please forgive me if I missed it. I really need to get Firefox working.

    I'm running a Dual 1.42GHz PowerPC G4 with 1.75Gb of RAM

    I had Firefox 3.0.3 running great with OSX 10.5.4.

    I install the new 10.5.5 update and now Firefox won't start up. I double click on the Icon in the Icon bar and it bounces a couple of times then.....nothing. I try double clicking the icon in the Applications folder and ...nothing.

    I re-install Firefox 3.0.3 and try again, then 3.0.1, then 2.0.0.17 and still nothing with any of them.

    I've also tried backing up then deleting the Firefox folder in the Application Support folder before re-installing and still nothing. I copy the folder back and still nothing.

    Please help...it's getting really frustrating.

    My next step I guess will be to re-install OSX 10.5.4. if I can't find other suggestions.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Check your Console - read the log files. Often times there will be an entry there that will tell you the cause of the problem. Even if there isn't an entry that tells the exact cause, there usually will be one that points to a crash log file. That WILL give the cause and details about what happened.
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
  4. Toddo thread starter macrumors newbie

    Joined:
    Oct 13, 2008
    #4
    Hey guys,

    Thanks for the reply.

    Looking at the console, I just get the message:

    "14/10/08 11:19:39 PM com.apple.launchd[61] ([0x0-0x36036].org.mozilla.firefox[852]) Exited with exit code: 1 "

    Makes no sense to me unfortunately.

    Yes I've read that post on Mozilla.com, but everything I've tried does nothing. Unless there's another way to create a new profile, I'm stumped.

    Thanks again guys. Looks like it's back to 10.5.4 again when i get time.
     
  5. prostuff1 macrumors 65816

    prostuff1

    Joined:
    Jul 29, 2005
    Location:
    Don't step into the kawoosh...
    #5
    This might be a corrupted .plist file problem.

    Look in user name/Library/Preferences/ for org.mozilla.firefox.plist

    Delete that file and then try relaunching firefox.
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    That means Firefox exited abnormally (exit codes greater than 0 indicate problems) It's unusually unhelpful though - most log messages are more helpful than that one. Ah well, if it still doesn't work after downgrading to 10.5.4 let us know.
     
  7. Toddo thread starter macrumors newbie

    Joined:
    Oct 13, 2008
    #7
    Serious thanks again for other suggestions. I really appreciate it.

    O.k. I tried deleting the org.mozilla.firefox.plist and restarting Firefox and still....nothing.

    I deleted anything that looked like mozilla and firefox files, re-installed 3.0.3, tried restarting Firefox and still....nothing.

    I wen't onto mozilla.com and downloaded the 3.1beta1 version (thinking it just might have a fix) after clearing all the firefox stuff again and tried installing it and....nothing.

    Thought about instead going to Opera, but it looks like the development has been abandoned since OSX 10.2...so no go there.

    I really don't want to go back to 10.5.4, as everything else is working fine, but I may have to go there this weekend.

    If there are any other suggestions, I'd love to know.
     
  8. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #8
    try creating a new profile and using it
    Code:
    ~# /Applications/firefox.app/Contents/MacOS/firefox -profilemanager
     
  9. Toddo thread starter macrumors newbie

    Joined:
    Oct 13, 2008
    #9
    Thanks for that suggestion. When I try that it says "Permission Denied". I've tried allowing everyone to have 'read and write' permissions on all folders in the path but still nothing also.

    Well my hand was forced when the drive crashed...again...and wouldn't boot up, so I recovered a Time Machine back-up from OSX10.5.4 (when Firefox did work) and replaced the battery -well it was over 5 years old and due for a new one-. But to my distress...still no Firefox!!!!!!!

    Aaaaaarrrrrrrrggggghhhhh!!!!
     
  10. Toddo thread starter macrumors newbie

    Joined:
    Oct 13, 2008
    #10
    I can't explain it, but today I boot up my Mac, double click on the Firefox Icon in the Toolbar and.....it opened! It did give me the option of restoring the previously crashed session or opening a new one - I did the latter - but it opened and works fine again.

    Go figure! I don't know.

    I am back in 10.5.4 land and using FF 3.0.1, but it works and I'm happy.
     
  11. Meredith macrumors newbie

    Joined:
    Nov 16, 2008
    #11
    Firefox 3.0.3 crashes

    This sounds very similar to what has been happening to me. I have a MacBook Pro, running 10.5.5 as well. Firefox takes 5 minute to finally launch, and lasts usually less than a minute before crashing, even after launching in safe mode. Interestingly enough, I happened to have Terminal open, and it gave the following message...

    macbook-pro:~ magmd1987$ fatal flex scanner internal error--end of buffer missed

    I'm only an enthusiast - what does this mean? I also have vmware fusion installed with windows xp, which I saw in the Mozillazine area was a problem for at least one other user (his post has gone unanswered).

    Thanks!

    Meredith
     
  12. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #12
    http://discussions.apple.com/thread.jspa?messageID=8227499&#8227499 may offer some clues as to solve your problem. The error message itself may be unrelated or due to a corrupt file on your disk Do a disk repair, restart, then try the suggestions on the link about if you are feeling adventurous.

    The old thread may or may not be related (in the future, consider starting a new thread for new/marginally related problems).
     
  13. labmatt macrumors newbie

    Joined:
    Apr 5, 2009
    #13
    many thanks

    that method worked perfectly!
     

Share This Page