Please help: Flash is broken, but only in Firefox and only for one user

Discussion in 'Mac Apps and Mac App Store' started by bollweevil, Apr 4, 2009.

  1. bollweevil macrumors 6502

    Joined:
    Feb 1, 2008
    #1
    The short story:
    When I go to certain websites that use Adobe Flash Player with Firefox 3 in one user account, the Flash doesn't work. Some Flash websites do work, such as Youtube. What in the world is going wrong? How can I fix it?

    The details:
    I have a MacBook Pro running OS X 10.5.6, it has two user accounts. One user account is mine, has administrator privileges, and gets most of the use. The other user account was created later, lacks administrator privileges, and gets little use. Both user accounts have Safari and the latest Firefox 3 (3.0.8) installed. The problem with Flash occurs ONLY in the second (non-admin) user account, ONLY in Firefox, and ONLY on certain websites.

    Websites with Flash that do work:
    1. YouTube.com
    2. Every website I could think of with a simple Flash intro

    Websites with Flash that DON'T work:
    1. pandora.com //The HTML loads fine, but there is a dead white box where the Flash UI should be
    2. Macromedia Flash settings manager //There is a medium white box where the Flash UI that allows you to change settings should be.
    3. seeqpod.com //Very odd failure mode: The Flash UI loads, and works. I click "sign in", and the "sign in" dialog appears. I type my username and password and click enter, and then the whole Flash UI freezes forever (well, for at least 30 minutes). This crash is unrecoverable.

    Note that all three of those broken websites do work in Safari in the non-admin user, and all three of those broken websites do work in both Safari and Firefox in the Admin user.

    What I have tried:
    1. Upgrading from Flash 9 to the latest Flash 10. No change whatsoever.
    2. Uninstalling all versions of Flash using the Flash Uninstaller for OS X 10.3 and up, available from Adobe/Macromedia, then reinstalling Flash 10. No change whatsoever.

    Please, please help. The other user needs Firefox for the plugins, and it would be very nice if Pandora and Seeqpod worked. Thanks.
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    Have you tried reinstalling Firefox? Or what about creating a new user account and copying the documents over?
     
  3. bollweevil thread starter macrumors 6502

    Joined:
    Feb 1, 2008
    #3
    I would be willing to reinstall Firefox on the other user account if I knew that my user account's Firefox would be completely unaffected. I don't want to risk my own cookies, bookmarks, history, passwords, plugins, certificates, autofill data, keywords, and configurations.

    I could try creating a third user account and transferring everything about the second user into the third user. That might be a waste of space, but I can delete users. Okay, that's my next step.

    While I am trying that, if anyone thinks of a great solution please let me know.
     
  4. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK

Share This Page