Please help, hanging on startup or Kernel Panic

Discussion in 'Mac Basics and Help' started by hardtofin, Mar 4, 2009.

  1. hardtofin macrumors newbie

    Joined:
    Mar 4, 2009
    #1
    Hi guys,

    I wonder if you good people can help me. I have a 2 year old iMac that was working fine until last night. I had just installed the "raw photo compatibility" update (although i think this is just coincidence) and shut my computer down.

    When i booted it up again 3 hours later, i got to my desktop but instead of seeing my usual 3 partitions (macintosh, home, windows xp) I only saw 2 - windows xp was missing. Not only this but my system was continuously beachballing.

    I was unable to force quit so after a few minutes i held in the power button for 4 seconds until it shut down. Upon reboot, i was (and still am) only able to get to the white screen with apple logo that you get on boot up. On this screen you have a little gear spinning round. This spins for some time then just as my computer would usually boot into the O/S, the gear stops and it hangs.

    Please can anyone offer me any help with this? I am running the latest version of Leopard and so far i have:

    Tried diagnostics mode - all diagnostics come back ok, even in extended test

    Single user mode - tried FSCK to repair, first time it made changes to drive, after that nothing.

    Tried safe mode - wont boot

    Tried booting from leopard cd - still hangs in same place

    tried booting from tiger on an external hdd - at same place it usually hangs, it kernel panics instead

    swapped ram out - exactly the same problem when using someone elses ram

    Im out of ideas, any help would really be appreciated. Thanks so much in advance and sorry for such a long first post. I am a regular reader or macrumors, just havent been to the forums before.

    Many thanks again

    hardtofin
     
  2. hardtofin thread starter macrumors newbie

    Joined:
    Mar 4, 2009
    #2
    update:

    I have removed the video drivers and caches in single user mode. My computer now boots although has no quartz support and has no 3d acceleration.

    I still however can not boot from a CD to put a fresh install of OS X on. Do you guys think this was the fault, just bad files in caches, or could it still be hardware?

    any opinions appreciated.

    thanks,

    hardtofin :)
     

Share This Page