PLEASE HELP! Hard Drive issue!

Discussion in 'Mac Basics and Help' started by MacYoukai, Aug 21, 2013.

  1. MacYoukai macrumors newbie

    Joined:
    Mar 9, 2009
    #1
    I recently upgraded my hard drive on my 2011 17'' Macbook Pro. I backed up the most important files and all before doing so, however, I forgot to backup my contacts, a mailbox, a few vacation videos, and the calendar. I have the contacts on my phone, however, I would like to get access to the other data if possible.
    I have Vantec's SATA to USB adapter, I used it for when I swapped out the hard drive in my 2006 Macbook Pro. The hard drive is found by the computer, but it refuses to mount it and labels the partition as "disk1s1" or some other numerical variable of that label. I have tried getting multiple computers to notice it to no avail. To double-check the adapter, I used my old 2006 hard drive with it, that loaded just fine.
    So if anyone here has any good ideas on what I can do, please let me know. The stuff that is left on there is not the most important stuff, but I would really like to have it.

    Would reinserting the drive as an internal drive allow it to be accessed? I came across some threads that suggest this may be some permissions issue. The drive is also labeled as 0xEE on the name field, but a partition is recognized.
    Any help would be greatly appreciated, I would really like to recover the remaining data.
     
  2. MacYoukai thread starter macrumors newbie

    Joined:
    Mar 9, 2009
    #2
    If this helps, I did a verification via diskutil in Terminal. It came up with this error: "Unrecognized Filesystem (-9958)"
    Eh... I feel really sick. I hope I can recover the files.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    Well, one way to do it might be this:
    - Put the old drive BACK INTO the MacBook Pro. Will it boot? What happens?
    - If you can get booted, I would suggest you use CarbonCopyCloner to clone its entire contents to a backup source (you probably need another hard drive)
    - Once you get the contents cloned, make sure you can read them with the drive mounted in the dock.

    That's one thing to try.
    Here's another.

    Could it be a conflict between the dock and drive?
    You could try a DIFFERENT dock, an external USA/SATA "dongle", etc.

    Here's the final recommendation:

    It involves data recovery software and an additional "scratch drive" to which you recover scavenged files.

    I had a drive (actually, a partition on a drive) that was in the same condition as yours -- that is, Disk Utility could not mount or repair the partition. I had "Data Rescue" (excellent software), but DR couldn't "touch" the partition, either -- again, because it could not be mounted.

    My solution (and yes, you're reading correctly) was to RE-INITIALIZE the entire drive into a single partition. You're probably thinking "re-initialize? Won't that DESTROY all the data?"

    Nope. When you re-initialize a drive, what you're really doing is wiping clean the DIRECTORY (i.e., the "index" that "points the way" to all the data on the sectors of the drive). It DOES NOT touch or erase the actual data itself.
    (VERY IMPORTANT: I did NOT "zero out" the drive, which DOES "wipe clean" the sectors. DO NOT do this!)

    Now the drive would "mount on the desktop".
    However -- it was "empty" (because the directory was "new" and "fresh").
    BUT -- the actual _data_ was still "out there", on the drive's sectors.

    Now -- Data Rescue could "attack" the drive. DR doesn't need the directory -- it can go "right to the platters" to scavenge up the data there. It then re-constructs the files and saves them on the "scratch drive". This is how you get the files back.

    Important: You WILL lose all previous folder hierarchies, and you'll probably lose most if not all of the previous file names. Remember, these things are "constructs of the directory", and you wiped that out when you re-initialized the drive.

    But again -- the actual _data files_ get recovered, and that's what counts.

    There is no promise this will work for you.
    Do so at your own risk.
    But it worked for me, when nothing else would.
     
  4. MacYoukai thread starter macrumors newbie

    Joined:
    Mar 9, 2009
    #4
    Thank you so much for your reply, Fishrrman, I appreciate your help! So the idea of remounting the drive is a possibility then?
    I am not sure I feel comfortable about initializing the drive as you described, but I will keep that in mind.
    I have multiple external drives, so having an extra drive for these things is no issue.
    Thanks again for the advice! I need to think about what action to take, but trying to boot it directly again seems like it may be what I will try next.
     
  5. MacYoukai thread starter macrumors newbie

    Joined:
    Mar 9, 2009
    #5
    Problem solved! I just wanted to post this to help anyone else whom might be suffering from the same issue with their hard drive. I put the hard drive back into the computer without doing anything else with it. All of my files were intact just as they were prior to my removing it.
    Thanks for the advice once again, Fishrrman! I had been considering putting it back in, but getting the outside advice to try that helped me solve the issue.
     

Share This Page