Please help I Deleted DKPG folder.

Discussion in 'Jailbreaks and iOS Hacks' started by Nkhan91, Jun 25, 2016.

  1. Nkhan91 macrumors newbie

    Joined:
    Jun 25, 2016
    #1
    Ok so my iPhone 6s+ has been jailbroken on 9.0.2 and has been running smooth since I did it. I wanted to try out some new themes so I downloaded anemone and a them called rein. After downloading this my phone started to respring like a few times an hour if I was using it. If I wasn't on my phone it would still respring or be all black until I did a hard reset. So I deleted the theme and anemone thinking this would help but it didn't. So I deleted all packages and jailbreak tweaks, that didn't work. I don't know what possessed me to play with ifile but I did, I thought it was a memory leak so I tried the trick where you set the value to -1 so the phone wouldn't respring if something was eating up the memory, that didn't work. So I'm looking in my ifile var/lib and I'm looking around and I see the 4 folders apt cydia dpkg misc. There I saw 4 or 5 files when clicked opened up my app for wechat so like a dumbass I deleted them. Now when I open cydia it was saying that I needed to update these 8 files which I've come to find out are .deb files. When I try to install them I get DPKG_Locked or I get "Couldn't configure pre-depend dpkg for ncurses, probably a dependency cycle". So researching and trying to install the deb files manually didn't work. I found a tutorial saying you can delete your DPKG file and copy one over from another jailbreak and once again I didn't do due diligence and ask that person if they were still jailbroken......they arent. What should I do??? Is cydia ****ed and I should just update or any way to fix this?

    Oh btw no more resprings.
     
  2. Deetlebug89 macrumors member

    Joined:
    Feb 2, 2014
    #2
    I don't know the answer to your question unfortunately, but next time just put the iPhone in safe mode ( power it off then turn back on holding the volume up button) then delete whatever was causing your problems and you wouldn't have any troubles like this... But I hope you sort it all out and don't have to lose your jailbreak because of it
    --- Post Merged, Jun 26, 2016 ---
    Also sorry I missed the part where you said you tried to delete the tweaks before venturing into ifile
     
  3. Nkhan91 thread starter macrumors newbie

    Joined:
    Jun 25, 2016
    #3
    None of the tweaks did it solely it was a mix of some type of cydia glitch or dpkg error because I deleted allllll tweaks and it was still happening. Until I deleted the dpkg folder that's when it stopped.
     
  4. bufffilm, Jun 27, 2016
    Last edited: Jun 27, 2016

    bufffilm macrumors 601

    bufffilm

    Joined:
    May 3, 2011
    #4
    If Cydia still works, try Cydia impactor to remove JB and then try JBing again.

    If Cydia not working, you are SOL in which case , I'd erase and restore. Of course, you lose the JB but at least you might JB again if one is released.

    And the next time you have a problem, ask for help. You clearly aren't as smart as you think to try it alone. That's how you got into this mess.
     

Share This Page