Please HELP! iBook Problems

Discussion in 'PowerPC Macs' started by HomerAK, Mar 2, 2007.

  1. HomerAK macrumors newbie

    Mar 2, 2007
    Hi, I am new to macrumors. There seem so many knowledgeable people that I was sure someone here would be able to help me. I've done a lot of googlng and I've not been able to find out exactly what is going on with my little lemon.

    Here's my problem. I recently bought an 14 in. iBook G3/700 and it seemed to be running fine for the first few weeks I had it. It would sometimes display the spinning ball (using AppleWorks or white trying to edit photos) but for the most part was fine. It has always showed a fairly slow startup, and a few times I've just pressed the power button after it being on the white screen with the gray apple and spinning gear thing--in excess of 15 minutes at times. After that, it would start up fine. Normally.

    I bought an original AirPort card for it and since installing it, on start up, I get to a blue screen that lasts for maybe a minute or 90 seconds. (I've been able to login maybe twice sine the card was installed.) I then get a OSX login screen (Name and Password) and it will not recognize any of my user accounts. I enter the information, wait, get the spinning ball, wait some more, back to the arrow, then the login window shakes slightly from left to right and back, and the password field goes blank. The name field continues to show the user name as I entered it.

    I've done a few things to try to remedy this (emphasis on TRY):

    -I tried booting from my OS 10.2 disk. That did not work because there is a 10.2.8 update installed and it will not allow me to Archive and Install. I cannot boot from the 10.2.8 Combo Update disk.

    -I ran Apple Hardware Test and that came back without any problems.

    -I am currently running fsck through Single-User mode. It has been on '**Repairing volume.' for 30 minutes or so. Is this a normal amount of time? I have no idea what some of the findings mean.
    'Invalid sibling link'
    'Invalid map node'
    'Missing thread record'
    'Invalid volume directory count'
    'Invalid folume file count'
    'Volume bitmap needs minor repair'
    'Invalid volume free block count'

    -I ran 'sudo diskutil repairPermissions /'.

    -I cannot restart in Safe mode. All I get is the gray apple with spinning gear.

    Is there anything else I could try? Can I use the Software Restore disks? They are for OS 10.1.4 & 9.2.2.

    Sorry for the long post. I thought posting as much info as possible would be helpful. My brain is swimming at this point and I am ready to throw the thing out into the snowbank! Thanks in advance!
  2. VortexOfPain macrumors member

    Dec 29, 2006
    Maybe try Disk Warrior? I've used it in the past and am now a firm believer in it.
  3. Reflow macrumors 68000


    Mar 30, 2005

Share This Page