Please help. Inbox getting flooded by GMail!

Discussion in 'MacBook Pro' started by Moridan, Nov 19, 2012.

  1. Moridan macrumors newbie

    Jun 22, 2010
    So I got my brand new retina Macbook last night. First Mac I've ever owned. So far, I'm loving.

    But what I'm not loving is the fact that the email app is attempting to download every email that's ever passed through my GMail account(s) (more than 20k emails).

    How do I get new emails to show up, but not have the Mac download all the old emails? What am I missing?

  2. AirThis, Nov 19, 2012
    Last edited: Nov 19, 2012

    AirThis macrumors 6502a

    Mar 6, 2012
    It's difficult to tell from your description, but I think you've configured Mail for POP instead of IMAP.

    Basically, POP downloads your mail from the server and stores the messages locally. IMAP on the other hand keeps the mails on the server (with the entire folder structure) and lets you access them from multiple devices.

    I suspect that you previously had a email account configured for IMAP and now have configured it as a POP account in Mail. I did this by mistake once and all my neatly arranged emails were downloaded from the server and stored in my inbox on my local machine.

    My suggestion is to check your settings in Mail and see if 'POP' is being used.

    Edit: I've included a screen cap to give you an idea what the options look like when you configure your email account in Mail. As you can see, 'POP' appears to be the default option

    Attached Files:

  3. Moridan thread starter macrumors newbie

    Jun 22, 2010
    Thanks for the suggestion. I checked and they both say "Google IMAP".

    For what it's worth, I'm running OSX 10.8.1
  4. Mal macrumors 603


    Jan 6, 2002
    Go into Gmail's preferences (via the website) and tell it not to sync the All Mail folder via IMAP. That should help with that.

  5. Moridan thread starter macrumors newbie

    Jun 22, 2010
    That seemed to do the trick. Thanks!

Share This Page