Please help, install disk wont eject, cant turn powerbook on!!!!

Discussion in 'PowerPC Macs' started by wendylloyd, Aug 12, 2009.

  1. wendylloyd macrumors newbie

    Joined:
    Aug 12, 2009
    #1
    Hi all, please help if you can. I bought a powerbook off ebay, it worked but on startup occasionally a folder icon would appear. I rebooted from the original discs which seemed to do the trick. However the original discs are too old for many of my apps, so I bought some newer install discs (osx 10.5) I put the install disk in and got the panic message 'panic: Im hanging here'
    The answer seems to be to run a disk repair (am i right?) However to do that I need to eject the install disc, I can't get the install disk out and of course it keeps tripping up everytime I start it. There is no secret little button to eject the disk manually. I have tried holding down apple and S but the install disk over rides everything and trips the mac up. I think ill be okay if I can just get this disk out! Vicious circle...
    Wendy
    :eek:
     
  2. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #2
    Why would you buy any other Powerbook install discs except the ones that are made for your machine?

    Other Powerbook versions will NOT work on your machine. You need to find the exact specs of your machine and find the correct install discs.

    Depending on what Powerbook you have, you have not indicated which one it is, you can sometimes manually eject the disc. On the Titaniums you can do this.

    It sounds like your problem is a failing hard drive anyway, thus the question mark with a folder icon. I'll bet your hd is dead and its just defaulting to the wrong install discs.

    You need a new hard drive. You can get out the dvd when you open up the computer to replace the hd.
     
  3. wendylloyd thread starter macrumors newbie

    Joined:
    Aug 12, 2009
    #3
    Thanks...

    but my friend came around and simply pressed eject and it worked for him! Don't you just hate people like that lol.
    The disc is for exactly the same spec machine, just a newer version of os10, I think im going Jaguar to Tiger.
    The problem is that the last owner deleted personal information and seemingly binned some important files. Hence the folder icon flashing up on start up. It hasnt done it since I rebootted from the original install disk, however that software is too old for my internet dongle.
    It may be like you say that the disks aren't compatible, which I suppose means I either upgrade to Leopard or nothing at all. Im tempted but dont want to pay £80 for the software when all the mac is used for is web-browsing.
     

Share This Page