Please help-iOS4 and mail issue: bypassing mailboxes

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iPhonelover2010, Jul 9, 2010.

  1. iPhonelover2010 macrumors member

    Joined:
    Jun 30, 2010
    #1
    Hello,

    I am running iOS4 on a 3GS. I noticed a strange issue after updating to iOS4. I have three mail accounts: gmail, hotmail, and exchange. When I tap the mail icon from the home screen, it takes me straight into my gmail inbox instead of taking me to the mailboxes page (where the unified inboxes are as well as the separate accounts). I have to tap on my gmail address on the top left hand side to get back to the mailboxes page (the one it was supposed to take me to first). Anyone else experiencing the same problem? Is there any way to fix this? :confused: This is sort of annoying!

    Thanks in advance.
     
  2. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #2
    I assume you've set up to monitor "All Inboxes"?
     
  3. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #3
    Sorry I'm not sure I understand what that means...:( I was referring to the main Mailboxes page where it has the Inboxes and Accounts section.
     
  4. androiphone macrumors 65816

    Joined:
    Dec 13, 2009
    #4
    is it because you exit the app in the mailbox?

    try exiting the app on the accounts screen and see if it still does it
     
  5. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #5
    I did, and it still does it. It happens when I open the mail app for the very first time, and even after that. Only sometimes does it take me to the all mailboxes page :(
     
  6. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #6
    If you look at the top of that page you will see "All Inboxes". Click on this to monitor all mailboxes.
     
  7. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #7
    Hey, yes, I did that. However, when I exit the mail app and reenter it, it still takes me straight into my gmail inbox...
     
  8. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #8
    At the top of the page the heading should be "All Inboxes". The pointed marker on the top left of the page should be labelled "Mailboxes".
     
  9. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #9
    Yeah, that's what I see when I enter "All Inboxes." However, when I first click on the mail app, it takes me straight into my gmail inbox (it says my gmail address on the marker at the top left of the page). This isn't even my default account (I don't even think that would matter, though). I have to tap the marker at the top left to go to the Mailboxes page. Is there anything else I need to do specifically to monitor All Inboxes?
     
  10. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #10
    You've got me stumped now! Providing you come out of "Mail" (press home button) whilst on the "All Inboxes" screen, it should remain like that for future occasions.

    Further than that....... :confused:
     
  11. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #11
    Ah, yeah, its pretty weird...but I don't want to be taken to the All Inboxes screen, I want to be taken to the Mailboxes screen. I think its an iOS4 problem, as this began happening after I upgraded from 3.1.3. I found others with the same issue, but apparently there is no fix: http://discussions.info.apple.com/thread.jspa?messageID=11768275#11768275

    :(

    Some more information: when I open the mail app for the very first time, it takes me straight into my gmail inbox. I then tap the gmail address on the top left hand side to go back to the Mailboxes screen. If I go back to the homescreen and then tap the mail icon again, it'll take me to the Mailboxes screen (since the app is still running in the background). However, if I exit the app completely (in the multitasking dock) and then click the mail icon from the homscreen/start it again, it'll take me straight into the gmail inbox again.
     
  12. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #12
    I've just tried exactly the same as you described (and BTW, I've got a couple of Yahoo and a Gmail accounts too). Mine remains on the "All Mailboxes" screen! As I said before - Sorry, but I'm stumped for ideas :(
     
  13. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #13
    Aw, that's okay, thanks a lot for your help, anyway. I did some troubleshooting with an apple rep today over the phone, but I still have the same problem. I'm going to an apple store now to see if I can get it fixed, I'll still report back if I find a solution in case others are having the same issue! :)
     
  14. Wegee macrumors member

    Joined:
    Aug 27, 2009
    #14
    Same for me, i remember this when i was using mail with multiple accounts but I could not solve the problem.
    Actually I'm not using mail anymore because on my 3GS ios4 it drains battery like hell :confused:
     
  15. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
  16. Wegee macrumors member

    Joined:
    Aug 27, 2009
    #16
    I had an idea: did you try to delete accounts and setup directly in the phone? Maybe you can create a profile with the mail accounts using iphone configuration utility.
     
  17. iPhonelover2010 thread starter macrumors member

    Joined:
    Jun 30, 2010
    #17
    The Apple tech with whom I spoke over the phone made me reset my phone to factory settings. I then manually added my accounts and had the same issue. I even deleted my gmail account, which left only my hotmail account in the mail app, but then the mail app would take me straight into the hotmail inbox! Weird, I know...I just asked a few of my friends and apparently they're having the same problem as well.
     

Share This Page