please help! Iphone 3g cannot be restored

Discussion in 'iPhone Tips, Help and Troubleshooting' started by crosslancer, Apr 3, 2011.

  1. crosslancer, Apr 3, 2011
    Last edited: Apr 3, 2011

    crosslancer macrumors newbie

    Joined:
    Apr 3, 2011
    #1
    hi, I've got a Iphone 3g 8gig running a jailbroken 4.2.1, i got this second hand and it had a problem with the wifi not finding any networks, so i tried restoring the phone via itunes 10 on a mac osx running 10.5.8,
    it started to restore but 3/4 thru the restoration, it gave me an error "The iphone "iPhone" could not be restored. An unknown error occurred (6015)".
    i tried to get it out of the 10xx recovery loop using tinyumbrella, what i did was, put in in dfu mode and clicked fix recovery on tinyumbrella, on the log it would say "fix recovery has finished. allow device to reboot!"
    after it reboots, it's still in dfu mode, i would try to restore the device using custom firmware but itunes would give me another error when preparing iphone(error 1600), i would try to get it out of dfu mode by holding down both the power and home keys until it restarts, when it does, it's back in recovery mode again.
    could someone please help me out? i really don't want to go to an icenter and shell out more cash.:(


    EDIT: WEll, I fixed it using ireb on windows with a custom fw 4.2.1 .. :D
     
  2. mateusdepaula, Apr 12, 2011
    Last edited: Apr 12, 2011

    mateusdepaula macrumors newbie

    Joined:
    Apr 12, 2011
    #2
    Im having the same kind of issue. But i jailbroke my iphone using a custom ipad fw 3.2.2 made by pwnage tool.( and that became a file named iPhone1,2_4.2.1_8C148_Custom_Restore.ipsw )

    So im wondering if i should use the fw made out of that or a new custom fw made from a real iphone1,2_4.2.1 ... what did u use?
     

Share This Page