PLEASE HELP! iPhone cannot be restored Error 1013

Discussion in 'Jailbreaks and iOS Hacks' started by Vin365, Feb 5, 2011.

  1. Vin365 macrumors regular

    May 10, 2009
    I tried updating my 4.1 Jailbreak to Apple FW 4.2.1 and when I first tried i got the error code "the iphone cannot be restored 1013" and then it goes into Recovery mode. So I stayed calm and it told me I would have to restore and update, well I am now on my 3rd try and about halfway each time(after it trys verifying the update) I get the error. It's like one big loop! Please please help me figure out a fix ASAP. :(
  2. klamse25 macrumors 6502a


    Oct 25, 2009
    Try kicking it out of recovery via TinyUmbrella.

    You used TU in order to update, right?
  3. Gavernty macrumors 6502

    Jun 25, 2010
    open tinyumbrella go to the advanced tab and uncheck the box that reads set hosts to cydia on exit. Close and restore through itunes.
  4. Vin365 thread starter macrumors regular

    May 10, 2009

    I just read a solution which was to go to
    and edit the HOST file. trying it now hopefully that does it.
    but for future references was I supposed to update with TU? i don't really care about unlock
  5. Los macrumors regular

    Jul 5, 2010
    Hey there, I just had the same error trying to preserve my 1.59.00 baseband. Here's what I did, opened up TinyUmbrella and let it run the TSS Server. I did SHIFT+UPDATE like I was advised to preserve it, but no go. I got an Error 21 and it would not bother with it.

    Frustratingly, I decided to go with TinyUmbrella running in the background and then SHIFT+RESTORE to 4.2.1. In the TinyUmbrella site they advice NOT to do this because TinyUmbrella would then not be able to kick you out of recovery mode. Another comment however mentioned that you could do that and THEN use the Greenpois0n jailbreak to jailbreak the device and you would then be fine.

    That is exactly what I did. Ran Tinyumbrella in the Background, click on SHIFT+Restore on iTunes to iOS 4.2.1, my device installed the firmware and then I got the normal Error 1013. Finally, I opened up greenpois0n and then put the device on DFU mode and hit on jailbreak.

    Be aware though that since the device is in recovery mode it can't turn off and then go into DFU mode, you gotta do it on the "Connect to iTunes" screen and THEN hit Jailbreak on greenpois0n. Good luck!
  6. Vin365, Feb 5, 2011
    Last edited: Feb 5, 2011

    Vin365 thread starter macrumors regular

    May 10, 2009
    didn't work d/ling TU and trying the check box fix.. crossing my fingers :(

    this fixed it thank you sososo much!
  7. gooberguy macrumors member


    May 17, 2010
    Buffalo, NY
    I had the same exact problem, and the same exact solution, at the same exact time :p

    should we restore the tick box in TU afterwards?
  8. ndfootball macrumors newbie

    Jun 26, 2010
  9. Gavernty macrumors 6502

    Jun 25, 2010
    glad to help :) I just went through the same process and same exact problem myself, so I know how annoying it is
  10. RaginAsian55 macrumors newbie

    Jan 22, 2011
    I had to use this fix to get my phone fully fuctioning after the bad update. I did NOT uninstall TinyUmbrella from my mac but I did leave the check box unmarked as mentioned above and applied those settings.

    So basically I did a combination of both methods and I got it working again.
  11. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    Did anyone know what kind of Iphone OP has? How can anyone trouble shooting the problem if we don't know which phone he/she has? 3G, 3GS or Iphone4?
  12. ellsworth macrumors 6502a

    Jun 13, 2007
    I'm trying to go everything that this video entail but I don't seem to have:

    in my host file.

    All I have is: localhost broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost

    I'm getting the : "iPhone cannot be restored" when trying to install my custom iOS 4.2.1 software.

    Any help?
  13. elan123 macrumors 6502

    Jan 26, 2011
  14. nutnezz macrumors newbie

    Apr 24, 2011
    i tried doing this multiple times and failed so many times i can no longer keep count:
    Mac OS X:

    Step 1. On your Mac, go to your “Applications” folder.

    Step 2. Now navigate to the “Utilities” folder.

    Step 3. Launch "Terminal".

    Step 4. Type "sudo nano /etc/hosts" (without quotes) and hit return.

    Step 5. Enter your password

    Step 6. Use the down arrow key to find the “” entries. Once the cursor is in front, make sure you comment out the line(s) by entering “#” in front of the text.

    Step 7. Save the file by pressing CONTROL+O.

    Step 8. Exit the nano editor by pressing CONTROL+X.

    Step 9. Restore your iDevice.

    and finally this worked for me!
    "On Mac:

    Open Finder
    Hold down COMMAND + SHIFT keys and press 'G'
    Enter "/private/etc/" in the field and press "Go"
    Find "hosts" file in the directory
    Drag the file to your desktop
    Open it in text editor
    Remove the line that has entirely or put a # at the beginning of it to comment it out
    Save the file
    Drag it back to the /private/etc/ folder.
    You'd need to enter your username and password to authenticate the move

    thanks to Shahrokhv from apple discussions!

Share This Page