Please help! Loss of data after upgrade to 6s

Discussion in 'iPhone' started by goox2, Oct 5, 2015.

  1. goox2 macrumors newbie

    goox2

    Joined:
    Oct 29, 2012
    #1
    I'm currently using iPhone 6 with iOS 9

    When I got my new 6s today,
    I backup my 6 and restore it in the 6s through pc.
    Though the restore seems smooth,
    I found that quite a number of apps disappeared in the new 6s
    Some of the icons of apps darken and need to dl one by one

    A msg showing "incomplete sync" popped up
    So, try to backup & restore again but still the same

    I think I'm messed up by the iCloud, but dunno what really go wrong.
    Anyone can help me?
     
  2. Thomi2 macrumors newbie

    Joined:
    Aug 21, 2014
    #2
    Your iCloud backup may be corrupted, or unusable due to iCloud restore function. It looks like iCloud had difficulties to restore backups these last days.
    I'm afraid you can't restore your data on your iPhone 6S.
    But, you could try those workarounds.
    Supposing you previously downloaded apps via the App Store, they are automatically stored onto your account.
    Go on the App Store, look for the update tab and tap on the "Purchased" icon. This will allow you to download all of your apps again.
    If you had photos, they normally were sent into the cloud and they will be automatically downloaded into your iPhone when you'll set up iCloud.
    Regarding music, messages, call history, etc. you might not find them into your new phone.

    To avoid the syncing error, use "Set up as new iPhone" instead of restoring your backup.
     
  3. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #3
    OP when you backed up your 6 did you get a warning that there were purchases (apps) on the phone that weren't in iTunes? If so did you tell iTunes to transfer those purchases from your phone to iTunes? What you describe can be caused by the phone having apps that don't exist in iTunes when you do a backup/restore.

    But more importantly, do you still have the 6 so you can start over?
     
  4. goox2 thread starter macrumors newbie

    goox2

    Joined:
    Oct 29, 2012
    #4
    Thx for the detailed explanation!
    But actually I always backup via itunes only

    And I did these backup & restore many times before with no problem
    Just dunno y it doesn't work this time
    So I guess it's caused by some setting about iCloud on my 6
     
  5. goox2 thread starter macrumors newbie

    goox2

    Joined:
    Oct 29, 2012
    #5
    Arrrrr, you reminded me. I did saw that warning before, but not this time. Why?

    Yes I still have my 6 and I can backup the data again
     
  6. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #6
    Sadly, anything at this point would be speculation on my part and just slow you down (like asking if you might have chosen the wrong backup to restore). If you do back up your 6 again and try another restore, keep in mind that any new stuff on the 6s will be lost unless you preserve it some other way. And congrats on your new phone! :)
     
  7. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #7
    You had apps that needed to be updated before you did a back and restore. Go to iTunes updates app the sync.
     
  8. goox2 thread starter macrumors newbie

    goox2

    Joined:
    Oct 29, 2012
    #8
    Thank you
    New iPhones are always lovely but this is the first one that upset me
     
  9. goox2 thread starter macrumors newbie

    goox2

    Joined:
    Oct 29, 2012
    #9
    I'll try, thanks!
     
  10. Thomi2, Oct 7, 2015
    Last edited: Oct 7, 2015

    Thomi2 macrumors newbie

    Joined:
    Aug 21, 2014
    #10
    Okay, I understand.
    Where are you trying to restore your sync from? iTunes or directly on your phone First-Use screen when prompted to choose a recovery option?

    If you do try from your phone, try from iTunes by plugging it to your computer while setting it up and vice versa if you are doing the restore from iTunes.

    iTunes may have missing files or incomplete data to recover that your phone don't have.
    (If you always backup from iTunes, it would normally show you the latest backups made with any other iOS devices that are compatible with the device plugged in to the computer)

    If that still doesn't work, you may try the following.
    (The following option will once again erase your data)

    Unplug your phone (the 6S has to be restored, not your 6 that contains the data, just to avoid confusion) it if it's plugged in to any computers.
    Enter DFU mode or Recovery mode by pressing the home button and the power on button for about 8-10 seconds and release the power on button while keep pressing the home button.
    If your phone restarts with the Apple boot logo, the procedure was not recognized by the phone.

    If you see literally nothing (like your phone is off) or an icon with iTunes, your phone entered respectively DFU mode or recovery mode.

    Plug it to your computer, and iTunes will tell you it has recognized a phone in recovery mode and it has to restored before being used.
    iTunes will search for the latest firmware compatible with your model, and restore it.

    You may retry to restore your data.
    Considering you restored your phone, if it says the sync restore is incomplete, it is most likely that it is corrupted.

    (All of this supposing that your shiny new iPhone 6S may have software failure, and that an all new firmware downloaded from iTunes may fix the problem)


    UPDATE -> If you backup your 6 with iOS 9, and that you're trying to restore onto your 6S that may run iOS 9.0.1, it may not work due to the fact that your backup is on an older version of iOS.

    I really hope you'll find a fix to the problem, and hope that helps a bit :)
     
  11. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #11
    I would do a new encrypted back up via iTunes from your old 6 and try it again.
     

Share This Page