Please help, macbook pro 2.4 is narcoleptic

Discussion in 'MacBook Pro' started by cannyt, Mar 1, 2008.

  1. cannyt macrumors newbie

    Joined:
    Mar 1, 2008
    #1
    Yesterday was such a happy day, I had been saving for months and finally got my Macbook Pro 2.4sr through bestbuy due to their sale. Today my new mbp does not like to wake after sleeping with power adapter plugged in. It goes to sleep, light starts fading in and out then when you open it nothing happens. I then have to hold the power button down till I hear it power down then I restart it. Also, the battery only has 98% health right out of the box using istat! I brought it to bestbuy and they told me everything is fine and would not switch me out for a new model unless I wanted to pay a restocking fee cause they couldn't duplicate the problem. If the battery has this low health after 2 cycles is there a chance I got an old build that has been in a box for almost a year? If anyone can help please do. Thank you to everyone in this forum, long time reader but this is my first post.
     
  2. warhead1 macrumors newbie

    Joined:
    Mar 1, 2008
    #2
    My battery reports 99% healthy and my MBP is the brand new multi-touch model
     
  3. hojoon0724 macrumors regular

    Joined:
    Jun 26, 2007
    Location:
    Los Angeles, CA
    #3
    same problem with a 3 year old powerbook.

    try doing a pmu reset

    i think for the mbp is holding the power button for 5 to 10 seconds when it's off.
     
  4. scienide09 macrumors 65816

    scienide09

    Joined:
    May 5, 2007
    Location:
    Canada
    #4
    I don't know about the sleeping problem, but have you tried calibrating your battery?
    Stolen from elsewhere on the forums.
    [​IMG]
     
  5. dmarch macrumors regular

    dmarch

    Joined:
    Nov 14, 2007
    Location:
    Big Sky, MT
    #5
    For the sleep problem, what's worked for me is instead of just closing the lid with the power adapter connected, is to click apple, then sleep. My MBP has not failed to wake since I've begun to use this method.
    Battery issue I don't know about.
     
  6. soccerjoe5 macrumors regular

    Joined:
    Feb 3, 2008
    #6
    some people reported that istat caused the problem, so you can try removing it or disabling the network component or something like that. that's what they did.
     
  7. cannyt thread starter macrumors newbie

    Joined:
    Mar 1, 2008
    #7
    thanks, taking off ISTAT fixed everything. Thanks for everyones suggestions and tips. I am a happy mac owner again!:)
     

Share This Page