Please Help! Macbook won't boot up after attempted Leopard install (Wont boot DVD/HD)

Discussion in 'MacBook Pro' started by ljump12, Jan 14, 2008.

  1. ljump12 macrumors 6502

    Joined:
    Jun 10, 2006
    Location:
    philadelphia
    #1
    Ok so I'll go through EXACTLY what has happened to my laptop in the past day.. please note that the laptop was NEVER moved from the desk while this has all happened. Also a couple other things you should know.. I had Applecare, but 6 months ago when i sent it in to replace the harddrive -- they said they found some water damage, and it would cost $700 to replace... so i just put in the harddrive myself for $50, and it has worked fine since... So I'm pretty sure I can't turn to applecare anymore...

    Alright...

    Yesterday
    One of my memory sticks went bad on me... (i had 2- 1gig sticks.) I took the bad one out, and the computer seemed to run fine on the single stick of memory.

    Last night
    I started to install leopard as an update over 10.4, seemed to work fine, though it was slow -- and finally i got to the leopard installation complete thing (please reboot the computer)... so I did...

    It starts loading up... shows the mac symbol with the loading circle thing... but wait, Oh *****, i was probally was supposed to take out the cd... So i turn off the macbook by holding down the power button... and I eject the cd, and then try to start it up...

    Not loading... *****.

    So after some mulling i decide, alright -- i'll reinstall again...

    I boot to the cd drive, choose my options, start the install, and go to sleep..

    This Morning
    I wake up.. the install hasn't moved at all... It's still at the same place where i left it..
    *****... so again I manually shut it off, and try and restart to boot from the CD again..

    NO GO....

    If I hold down C to boot from DVD
    The computer attempts to read the disk.. CD drive seems to power down.. then try again.. Then it ejects the cd, and goes to the Apple logo with the spinning circle, but never loads. I've tried it with My old 10.4 disk, and the new leopard disk. Same result on both. neither disk seems scratched either.

    If I just boot up regular
    It goes to the apple logo with spinning circle.


    SOOOO...

    I tried resetting the PMU, and PRAM

    Is it likely that it is my superdrive gone bad, at a horrible time? If so I guess i'll just buy one on eBay and replace it myself. Is there any way to test it?

    Could there by another problem wrong with it?

    Please help me troubleshoot this! I'd be very appreciative -- I'm a poor college Computer science student that needs his computer to work for his classes.

    Thanks All!
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Water damage doesn't develop by itself.

    You have messed up the install by hard power down the first time. Note Mac OS is not like windows where a CD/DVD would prevent it from booting from the harddrive properly. In fact, after a proper install, OS X AUTOMATICALLY boot up to the harddrive.

    You actually need to reset System Management Controller (SMC), not PMU.

    Have you tried holding OPTION key when you power on? That will ALWAYS allow you to choose a startup disk.

    Non-legit copies of Leopard seems to have problem with booting on certain systems... Do you have a retail disk?
     
  3. ljump12 thread starter macrumors 6502

    Joined:
    Jun 10, 2006
    Location:
    philadelphia
    #3
    I never claimed anywhere that I didn't cause water damage, i just said that it shouldn't cost $700 to fix it.

    It is a legit retail leopard DVD.
     
  4. ljump12 thread starter macrumors 6502

    Joined:
    Jun 10, 2006
    Location:
    philadelphia
    #4
    is it possible, if i could find a Firewire or USB external CD drive -- that i could boot the OSX cd off of that, and reinstall OSX. This would let me know if it was indeed the superdrive gone bad..

    Is that an option?

    Also, if i hold down the option key... It tried to read the dvd for about 15 seconds... then ejects it, and gives me only one option "Macintosh HD" which doesn't work.
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
    At least you admit it about the water damage, sorry about that. (unlike some people who said oh my MBP is low quality because it seperated by itself, but actually the problem was due to them installing a new HD and did not put it back properly).

    With water damage, they would have to replace some major part(s) and test, that's why it costs so much.

    All macs with firewire can boot using firewire devices, be it DVD drive or harddrive. Intel macs can also boot using usb devices. So MBP can boot from both usb and firewire.

    I typically use a firewire DVD reader / burner (about $60 if you put it together), as it's faster.

    Do you have another mac? You can try it via firewire target disk mode, using another computer as the DVD drive.

    Try removing the battery and power adapter for an hour first.
     
  6. hotsauce3868 macrumors member

    Joined:
    Oct 28, 2007
    #6
    before going through the hassle of booting from another mac, go into disk utility and see if your hard drive failed or see if you can find any problems there. My computer got really slow and i could not boot. took it to apple and they told me my HDD was dead. after only 3 months of use on a SR MBP.
     
  7. swearbymac07 macrumors member

    Joined:
    Dec 13, 2007
    #7
    Install Problems and Solution (It happened to me)

    Hello there,

    The same thing happened to me with Leopard Install, only i didn't hard power down, it just wouldnt boot. So what I did was boot into the Installer. DO NOT click Continue just leave it and Choose Utilities from the Top Menu and open up Disk Utility. Format your Disk if there is nothing you want on there (there won't be if it won't boot) Then run through the install again. Once completed, leave the computer reboot and LEAVE IN the Dvd once Leopard is running and you are on the Desktop, Eject the Dvd and you should be right. This is what worked for me. It also worked when Boot Camp erased Mac HD and Windows so it was just a gray screen at startup :)

    If the Drive wont boot it, Press Option at startup and wait till Startup Manager appears, Press Eject on the Keyboard and get the Dvd Out. Then insert it again, wait for it to read and show up. Then boot from it. That should work.

    Hope this helps you

    Cheers
     
  8. ljump12 thread starter macrumors 6502

    Joined:
    Jun 10, 2006
    Location:
    philadelphia
    #8
    The problem was indeed that my superdrive went bad at the most inoppurtune moment possible.

    After using a friends external USB CD drive, i was able to boot up and reinstall OSX.

    Thanks erveryone.
     
  9. HolyJaw macrumors newbie

    Joined:
    Sep 27, 2007
    #9
    same prob. Put in the leopard disk and ran utilities > disk utility.

    Verifying volume.
    Checking HFS Plus volume.
    Checking Extents. Overflow file.
    Checking Catalog file.
    Invalid node structure.

    Rebuilding Catalog B-Tree.

    The volume could not be repaired.

    Error: The underlying task reported failure on exit...



    Any hope?
     
  10. HolyJaw macrumors newbie

    Joined:
    Sep 27, 2007
    #10
    Hate to double post, but this should help anyone who's been looking at this topic for advice and has yet to find something applicable to them.




    In the long run, after my last post, the disk was completely unrepairable. My only option seemed to be turning to the $100 Disk Warrior program.

    However, I judiciously sought out a friend who also had a mac. Let me give you some simple mathematics:

    Mac + Mac + FW 800 Cable = Magic.

    There you have it folks.

    Anyways, we connected macs via FW800, he booted up, then I booted up holding down 'T' (for Target Disk Mode btw) and my hard drive essentially became another disk on his local network so to speak. (This was done at a Starbucks.)

    Immediately, an error popped up on his screen, "The disk KickAss (my Mac's Volume name, heh) could not be repaired." Forging on, I opened Utilities > Disk Utility on his computer, selected my Mac partition (on my mac I have an 80 GB OSX and 30 GB Windows XP partition(s)) and hit "+ New Image". Saved it, and boom (as the Steve would say himself), there's my backup.

    After that, it was safe to erase the Hard Drive, reformat, and install Leopard for a clean install. After a basic hard drive erase failed to allow Leopard to install, (Once I had the leopard DVD in and running) i went to Disk Utility (from the menu's up top running off the DVD) and did a 7-Zero pass. This worked, and voila, boom, and bam. Fresh install.

    Trasnferred the backup DMG of my old partition, mounted it, then went to Utilities > Migration Assitant and told it to migrate a apps, settings, etc. It only had a problem with the "Users" migration, but everything I needed from there was easily migratable by hand.

    And there you have it folks, an unnecessarily long, verbose, and ADD-infested post that will affect very few peoples' lives. But I hope I have helped in some way shape or form. Or at least reposted in great length what someone else may have already stated in much fewer words.
     

Share This Page