Please Help Me Retrieve Data

Discussion in 'Mac Basics and Help' started by TenFour, Dec 10, 2007.

  1. TenFour macrumors member

    Joined:
    Feb 12, 2006
    #1
    You guys have been so helpful in the past, please help me boot my Mac to salvage my data.

    Details are as follows:

    Beige G3 (233 MHz)

    For the longest time, when I boot up, the screen displays a message half way through:

    "An AppleShare system error occurred. (Please run the Chooser to activate AppleTalk.) If you have volumes set to mount at startup you may need to throw away your AppleShare Prep file. Consult your documentation."

    I then click OK or hit enter, and the computer finishes booting up.

    Last night, I opened the Chooser and ACTIVATED AppleTalk so that I could backup my data onto my G4 PowerBook. After I restarted the computer it took a very long time to boot up. Once it finally booted, I reopened the Chooser and DEACTIVATED AppleTalk once again to put things back to normal. My subsequent attempts to boot up show me the same old message about an AppleShare system error, but my KEYBOARD and MOUSE will not respond. As a consequence, I cannot click OK, and my computer will not finish booting up. The data that I was trying to backup is now inaccessible.

    Booting with extensions off won't work because my keyboard won't respond, nor can I launch control panels at startup.

    Please advise, any information would be appreciated, the information on my drive has been backed up recently, but the latest information saved has not been backed up and it is vital to my livelyhood.

    Thank you very, very much!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    I'm assuming you're running Mac OS 9 on that Mac, correct? If that's the case, then you should try the following:
    1. Make sure the keyboard and mouse are securely connected to the computer. A loose connection is the most common cause of this issue.
    2. Shut the computer down, disconnect the keyboard and mouse, reconnect them, and attempt to reboot. Does the keyboard respond now?
    3. Try a different keyboard, cable, and/or mouse, if you have them.
    Other than that, I'm not sure what's causing the issue you're having. I would recommend going into Macintosh HD:System Folder:preferences and finding the AppleShare Prep file, then sending it to the Trash once you get the keyboard problem solved.
     
  3. TenFour thread starter macrumors member

    Joined:
    Feb 12, 2006
    #3
    First of all, thank you for your response. I'm actually running 8.6 because its all that I need, the G4 PowerBook is fully up to date though. I did indeed check the connections, but that wasn't the problem. I tried another keyboard on your suggestion, but that didn't pan out either. I'm thinking that I might pull the USB 2.0 card and re-seat it, but I can't see that working. Thanks again for offering your help, though. I appreciate your time.
     
  4. heatmiser macrumors 68020

    Joined:
    Dec 6, 2007
    #4
    I always like to look at the worst-case scenario, and move from there. Let's say you can't get what you're doing now to work. What will you do? Here's what I'd do. I'd get the hard drive out of the iMac, I'd buy an enclosure from Newegg, and I'd use some recovery software to get the data off the drive and onto my working computer. Altogether, the most time-consuming thing would be removing the drive.
     
  5. TenFour thread starter macrumors member

    Joined:
    Feb 12, 2006
    #5
    Thanks for the advice. Its a little late here right now, but I'm going to fiddle with this tomorrow and see what I can do. I know that if I don't get my computer booting up within a few hours I probably never will. In that case, I think I'll put your suggestion into action. The computer itself is old and of little use to me, I just don't want to see my work lost to the ages if I can help it. I appreciate that you took the time to offer your advice... thanks a million!
     
  6. TenFour thread starter macrumors member

    Joined:
    Feb 12, 2006
    #6
    Should I Zap PRAM or reset CUDA?

    Hi All,

    USB 2.0 still not recognizing keyboard or mouse on Beige G3, should I zap the PRAM or reset the CUDA, if so, which first. Will either of these mess up my computer more. The computer seems to be okay, I just can't click OK on the message that pops up half way into booting (re: FileShare) because keyboard/mouse won't respond. I don't want to zap or reset and create further problems. Also, I'm running 8.6 (please, no jokes), if I try to boot from a OS 9 disc and somehow it works, will all my data survive?

    Any help is much appreciated.
     

Share This Page