Please help me...several problems with iPhone...

Discussion in 'Jailbreaks and iOS Hacks' started by Alistair1990, Oct 27, 2007.

  1. Alistair1990 macrumors member

    Alistair1990

    Joined:
    Apr 15, 2007
    Location:
    Norbiton, Greater London, UK
    #1
    OK so I had an unlocked 1.0.2 on Orange here in the Uk and saw the modmyiphone guide to upgrade to 1.1.1. I followed the instructions until the point where iTunes should recognise my phone as new and ask if I want to backup etc; this did not happen and it just synced as usual so I guessed the process had not worked. However due to being at the stage I was the phone was not working as a phone so I re-installed Unlock.app through cyberduck, let that do its business and then had my phone back to normal.

    However next time I plugged my phone in, iTunes says I need to restore the firmware and it shows the 300mb problem. I clicked restore and selected the 1.0.2 firmware I had previously downloaded, this appeared to download but nothing else happened.

    Also, cyberduck is connecting but no longer transfering files to my iPhone and Terminal will disconnect whenever I try the 1.1.1 upgrade.

    I'm a bit out of my depth here and really starting to panic :confused:

    Thanks in advance,
    Alistar
     
  2. ellsworth macrumors 6502a

    Joined:
    Jun 13, 2007
    #2
    if you do a search for "iPhone Software Updates" on your computer, you should find a file called: "iPhone1,1_1.0.2_1C28_Restore.ipsw" I believe this should be the file you are trying to restore your iphone with. When I first downloaded this file from a off-Apple-site, and I had to place it in that "Iphone Software Update" folder and go into itunes.... and it recognized it and did everything fine. I hope this is what you need.
    -Ellz
     
  3. Alistair1990 thread starter macrumors member

    Alistair1990

    Joined:
    Apr 15, 2007
    Location:
    Norbiton, Greater London, UK
    #3
    Thanks for your reply but I'm afraid I've tried this a few time. I put the file into the 'iPhoe software updates' folder and tried again. As before there was a progress bar in iTunes says 'Extracting software' but when this completed nothing else happens. :confused:

    Basically, I have 1.0.2 software and my modem firmware is 03.14.08_G (don't know if that will help) and my phone has the 300mb problem as reported by a few others.

    Any more suggestions?

    Alistair

    *EDIT* I solved the problem by SSH via cyberduck and then re-naming var/root/media to var/root/media old.
    This then allowed be to restore to 1.0.2 and unlock again using the modmyiphone guide.
     
  4. ellsworth macrumors 6502a

    Joined:
    Jun 13, 2007
    #4
    Wow. I would have never guessed to do it that way.. Glad you figured it out!
    Cheers!
     

Share This Page