Please help me unlock my Iphone

Discussion in 'iPhone' started by tuck88, Oct 7, 2007.

Thread Status:
Not open for further replies.
  1. tuck88 macrumors newbie

    Joined:
    Oct 6, 2007
    #1
    Hi,

    I am trying to unlock my Iphone 8gb refurb for use in the UK... I've followed all the instructions on www.hacktheiphone.com and everythin went smoothly upto this point... now I have launched Ibrickr, and when i click free my iphone... I am getting the same message over and over:

    Download the iPhone firmware
    Looks like you need to download the iPhone firmware. Fire up iTunes with your iPhone plugged in, and hit the Restore button. Once the download starts, unplug your iPhone. When the download finishes, click away the error message in iTunes, and close iTunes. Plug your iPhone back in, and click Check again.

    I have restored the firmware to 1.0.2 numerous times now - can anyone give me any advice please? or maybe a link for different software to unlock the phone, as this does not seem to be working for me.

    I have checked the firmware on my phone - it is the correct; 03.14.08_G.

    I have tried the method of starting the update on itunes, but taking out the iphone before it installs, and then trying ibrickr again - with no luck.

    I was originally running itunes 7.4.2 but now 7.4.0 and this has made no difference.

    and I have also tried using PQ's One Click Unlock - which isnt letting me past the registration screen with the key they gave me when i purchased it (extremely frustrating after paying $40 for it).

    Any suggestions would be greatly appreciated, I have now been tryin for a total over around 7 hours over the last couple of days, I really cant get my head round why it wont work... and finding it increasingly frustrative that i cant use my shiny new iphone here in the UK!

    Thanks
     
Thread Status:
Not open for further replies.

Share This Page